+ Start a Discussion
Kathryn PuzzangheraKathryn Puzzanghera 
Hi, I'm getting the error message: There was an unexpected error in your org which is preventing this assessment check from completing: System.DmlException: Process failed. First exception on row 0; first error: NO_APPLICABLE_PROCESS, No applicable approval process was found.: [].  I'm working on the module "Customize How Records Get Approved with Approvals".  I've seen that other people have gotten the same error, but none of the solutions seem to apply for whatever is messing mine up.  I've included a screenshot.  Any advice would be appreciated!  Thank you in advance!
User-added image
Best Answer chosen by Kathryn Puzzanghera
Bala Gangadhar VadlamuriBala Gangadhar Vadlamuri
Hi Kathryn Puzzanghera, Initial criteria should be "Account: Type equals Prospect". try changing it.
Srini D 14Srini D 14 
I wanted to pass data from visualforce page to apex class based on user clicks ?
Best Answer chosen by Srini D 14
Lakshmi Deepak InkurthiLakshmi Deepak Inkurthi
Using Apex Cookies you can able to get this done 
reference : https://developer.salesforce.com/forums/ForumsMain?id=9060G0000005f0DQAQ
site : https:lakshmideepak.com
Pieter Calitz 12Pieter Calitz 12 

I previously had a Developer Account where I added an app (+- 6 months ago)

Now, when I try to log in on that account, it does not recognize me.
I tried to change my password. Salesforce says it sent me an email but it never arrives
I need to get the account back because all the work has already been done

It was a connected app

I had to create a new account under a different name just to be able to post here

Please help!

Best Answer chosen by Pieter Calitz 12
NagendraNagendra (Salesforce Developers) 
Hi Pieter,

Sorry for this issue you are encountering.

In order to check the status of the developer account Login into your any of your developer editions then navigate to:

Setup > Company Profile > Company Information

OR just search "Company Information" in the quick find box

On that page, you can scroll down and see as below:

User-added image

But as you are saying that you are unable to login and not receiving the password reset link, may I suggest you please reach out to the trailhead support team with the respective org username for a better and quick assistance on the above issue.

You may reach the support team at the below email address. Note: The FAQ says that "Developer Edition organizations continue to be available as long as these organizations have some type of activity within the previous six months".If not the account gets expired.

Hope this helps.

Kindly mark this as solved if the reply was helpful.

I need to update a field called No of Agents with the count of agents in that zone (North, South, East, West). The zone field is on agent object and no of agents is on zone object. I have written the below logic.

I'm stuck with the if clause part. Can anyone help me with this?

Name is a field on zone object with picklist values of zone

On No of Agents field,
public class NoofAgents {
    List<Zone> zonestoupdate = [SELECT Id,Zones__C FROM Agent__C];  
    for(Zone z:zonestoupdate)       
        Integer NoofAgents = [SELECT count() FROM Agent__C WHERE Zones__C == North];
        if (Name__c == North)

it should show the count of agents in that zone

Best Answer chosen by SFDC 18
Bala Gangadhar VadlamuriBala Gangadhar Vadlamuri
public class NoofAgents {
    public NoofAgents(){
        for(zone__c z : [SELECT Id,Name,NoofAgents__c FROM Zone__C]){
            z.NoofAgents__c = [SELECT count() FROM Agent__C WHERE Zone__C =: z.Name];
            upsert z;

This Code will update for all the zones.

Choose this as best answer if you like.

I am working on Trailhead module: Test your Process. I followed all the steps in creating Process Builder through Trailhead and I am getting below error:
Challenge Not yet complete... here's what's wrong: 
There was an unexpected error in your org which is preventing this assessment check from completing: System.DmlException: Insert failed. First exception on row 0; first error: FIELD_CUSTOM_VALIDATION_EXCEPTION, Account number must be 8 characters long: []
Can one of you help or let me know, what I am doing wrong.
Best Answer chosen by Rama NPSP
Roman RybenskiyRoman Rybenskiy
Do you have a validation rule on this object? Try to deactivate all validation rules on this object and run the process builder again 
Best Answer chosen by Harshitha kaur
Narender Singh(Nads)Narender Singh(Nads)
I guess you are trying to change the access specifier of a class which contains a method declared as global. In order to resolve that, you must first declare that method as private. Only then you can set the access specifier of your class to private.

Let me know if it helps.
C R 4C R 4 
The verify steps of the Trailhead "Build an Account Geolocation App" are shifted by one unit.
When trying to validate the first or second Unit, an error pops up due to a missing file, which will be introduced in the next unit.
Build an Account Geolocation App verify error
Best Answer chosen by C R 4
RakeshRakesh (Salesforce Developers) 

Sorry for the issue you encountered.

We will fix this issue soon, Please Implement all units in the org thoroughly, then verify the units one by one. You will be verified. I have cross verified executing the same its cleared.

Please mark it as solved, if this reply was helpful.

I tried many times... but receive the same error message : "Challenge Not yet complete... here's what's wrong: 
Formula in custom field 'Account Annual Revenue' is not correct. Check the instructions."
I followed all instructions & get the right results. It's a basic & very simple formula.
Do someone else encounter the same issue ? Any solution ?
Best Answer chosen by Minkesh JAHERALY
I created a new Trailhead playground... entered exactly the same formula... and finaly could validated the challenge
Michelle Daniels 11Michelle Daniels 11 
I'm working on the Trailhead "Build a Community with Knowledge and Chat" because I really want to learn how to use the Chat Snap ins for communitites. I'm getting stuck on the "Create a Chat Snap-in" section. It says to go to the Visualforce pages and copy just the beginning of the address which is https://c.na35.visual.force.com/apex/CommunitiesTemplate. So I am copying  https://c.na35.visual.force.com. Then it says to create a new CORS with this copied address. However, when I copy this into the new CORS original URL pattern then it will not save. Can anyone tell me what I am doing wrong? I can't move forward without this step and I really want to learn how to do this. Thank you!
Best Answer chosen by Michelle Daniels 11
Bhavishya MoolyaBhavishya Moolya
Hey Michelle,

I tried using chrome browser to create the new CORS, it worked for me. I think browser was the issue with this unit.  
Sean OldroydSean Oldroyd 
Our sandboxes updated to Version: Summer '18 Patch 3.5 on 5/5/18.  Since the update an existing validation rule is causing failures when updating the record that the rule is associated with.  The rule fires on an encrypted field and is throwing a Invalid (null).  A previous known issue I found here is similar but it says it is fixed (https://success.salesforce.com/issues_view?id=a1p30000000jaT3AAI&title=validation-rule-occurring-with-invalid-null-when-org-has-encryption-enabled).  I also tried the work around in the known issue, however the rule still throws the error.
Best Answer chosen by Sean Oldroyd
Raphael FonrougeRaphael Fonrouge
We reproduced the same issue on custom objects.
The workaround (https://success.salesforce.com/issues_view?id=a1p30000000jaT3AAI&title=validation-rule-occurring-with-invalid-null-when-org-has-encryption-enabled) proposed by Salesforce (set the debug filters for 'Validation' to 'None') works when running Apex tests from the the developper console or when activating debug logs for a user. The remaining problem is that I don't know how to define these filters when running tests from my dev IDE...