+ Start a Discussion
Amod BAmod B 

Enable Lightning Knowledge option is not available on Knowledge settings page in my developer org

Hi,
I am working on 'Build a Community with Knowledge and Chat' trail and inside 'Enable and Configure Lightning Knowledge' module, I am not able to enable Lightning Knowledge as I cannot see this option in my developer org.Knowledge Settings screenshot missing the 'Enable Lightning Knowledge' option

Because of this, I am not able to complete this module. Please help!

Thanks!

Best regards
NagendraNagendra (Salesforce Developers) 
Hi Amod,

I have tried the same in my developer org which is working absolutely fine for me.

Before getting into knowledge settings may I request you please confirm that did u go through the below navigation?

Setup==>Users==>Click on edit button next to your name==>then check the knowledge user check box and do a save.

If this is done please refresh the page or log out of your org and please log in once again.Now you should be able to see the lightning knowledge option with a check box in the lightning knowledge settings as below.

For your reference please find the below screenshot.
User-added image

Hope this helps.

Please mark this as solved if it's resolved so that it gets removed from the unanswered queue which results in helping others who are encountering a similar issue.

Thanks,
Nagendra 
Amod BAmod B
Hi Nagendra,
Thanks for your help! I have already checked Knowledge User checkbox for my user. Please see below.
User-added imageUser-added image
I logged out, refreshed the page, but I am not able to get Lightning Knowledge setting.

Best regards,
Amod
Matthew BertschMatthew Bertsch
I'm having the same issue, but even worse.  When I do a search in the quick find...I can't even find "knowledge" at all:

User-added image
John Adams 38John Adams 38
Hi Amond,
I had same issue. Went to Setup >> Apps >> Sampel Console and edit
Then under Chose Navigation Tab Items added "Knoweldge Classic"  to slect Items 
Under Knoweldge Settings I did have "Enable Lightning Knowledge" set as True but didn't seem to matter.

Regsards
John 

 
Rajesh Sahoo ADMRajesh Sahoo ADM
It seems the issue with Salesforce Winter 18 release. I did it on June and it was working. But now its not. 
Annemarie Strand 1Annemarie Strand 1
I have the same issue - did anyone find a resolution? 
Xiaobai Wang 4Xiaobai Wang 4
I have the same issue.
Aaron CosentinoAaron Cosentino
I am experiencing the same issue.
Thomas Egeling at SalesforceThomas Egeling at Salesforce
Enable Lightning Knowledge from Classic UI by following these instructions: https://help.salesforce.com/articleView?id=knowledge_lightning_enable.htm&type=5
  1. From Salesforce Classic Setup, enter Knowledge in the Quick Find box and click Knowledge Settings.
  2. If you’re new to Knowledge, enable Knowledge in Salesforce Classic by selecting Yes and clicking Enable Salesforce Knowledge.
  3. On the Knowledge Settings page, click Edit.
  4. Select Enable Lightning Knowledge.
  5. Click Save.
Aaron CosentinoAaron Cosentino
Thank you this resolved the issue!
Zoe McLeanZoe McLean
Many thanks, very much to the root of the problem.