+ Start a Discussion
force shahidforce shahid 

How to delete / hide standard Field ?

Hi Friends,

I want to delete or hide standard field. How it is ?

In my Page layout , the standard field is not apper. How it is ?
Leo10Leo10
Hi,
You need to ovrride the whole page layout, you can't just hide these fields.

Here is an eg for overriding lead page layout
http://rjpalombo.com/2012/04/override-a-standard-salesforce-page-with-visualforce/

Thank you
Roshni RahulRoshni Rahul
Hi shahid,
Inorder to remove the standard field from view,
Go to the fields which you want to hide and select there link and select the Set Field-Level Security button and uncheck the Visible checkbox for the profiles you do not want to see those particular fields.

Regards
Roshni
force shahidforce shahid
Hi Roshni,
 I select the Field-Level Security button and try to uncheck checkboxs, but these are uneditable . How cai i do this ?
rahul kumar 226rahul kumar 226
Hi Force shahid,
please find build and select the "Customize" under the customize option you find a standard object.in the below screenshot  
User-added image
select the Account object
User-added image
After selecting the "Account" select the "page layouts"
User-added image
Once you click the edit button you will get "Account layout" where you can remove the field depending upon the requirement.

Best Regards
RahulKumar
force shahidforce shahid
Hi Rahul,
I want to edit the standard field in custom object ? how ?
EldonEldon
Hi Shahid,

You can remove them from page layout. Goto page layout of your custom object>drag and remove fields from page layout. You can't remove required fields but you can remove standard fields like owner, created by,last modified by from page layout.
Let me know if having any other issue.
Rahul_kumar123Rahul_kumar123
Hi Force shahid,

You can remove the standard fields like  "owner", "created by", "last modified by" from the page layout. If a field is not required at the sobject level, you can remove it from the page layout.  

please Mark it as the best Answer if it resolved the problem.

Best Regards 
RahulKumar