+ Start a Discussion
Erwan YhuellouErwan Yhuellou 

Trailhead - Salesforce DX Convert and Deploy an Existing App - error mdapioutput


Curently doing the App Development with Salesforce DX / Convert and Deploy an Existing App.

I have the following error when performing the final deployment task :

Error  mdapioutput/applications/DreamInvest.app        DreamInvest    In field: tab - no CustomTab named Fund_Explorer found
Error  mdapioutput/flexipages/Fund_Explorer.flexipage  Fund_Explorer  You must have My Domain deployed to use component c:FundTileList.
Error  mdapioutput/tabs/Fund_Explorer.tab              Fund_Explorer  In field: flexiPage - no FlexiPage named Fund_Explorer found

Do you know why ?

Alap MistryAlap Mistry
Hello Erwan Yhuellou,
Are you enable My Domain in your org? If not, then enable My Domain or use Trailhead Playground (Because it has enabled My Domain) to check your challenge. For enable My Domain, check this step: https://trailhead.salesforce.com/en/projects/slds-lightning-components-workshop/steps/slds-lc-1
If it is useful,then mark it as best answer to close this thread.
Alap Mistry
Joseph Ortiz 19Joseph Ortiz 19
I'm running into the same problem. It seems that the DreamInvest managed package has missing components.
William HurleyWilliam Hurley
Hello Alap,
Your solution does not help fix the problem. Please advise what we need to do to successfully complete the challenge.
Alap MistryAlap Mistry
Hello William Hurley,
This is solution based on Erwan Yhuellou's error.
Can you check your application directory in local system? Path: [Your Path]\MutualFundExplorer\mdapioutput\tabs (in Windows System). If Fund_Explorer.tab file is given, then no problem. If Fund_Explorer.tab is not given, there install package again.
You can login into scratch org (which contains MutualFundExplorer installed package) then open Mutual Fund Explorer. If this app has Fund Explorer tab, then no problem. If this app hasn't Fund Explorer tab, then may be error occur and uninstall that package and install it again.
Alap Mistry
Muhammad Yusuf 8Muhammad Yusuf 8
I think you are trying to deploy your project to DevHub you created for SalesforceDX. Instead, you have to deploy it to your playground, if the playground is not set up yet then use the following URL to do so. 

MyTPO is your trailhead playground not your devhub
sfdx force:mdapi:deploy -d mdapioutput/ -u MyTPO -w 100

For some reason the permission set does not have the Fund Explorer and Funds tabs set to visible. If you edit the permission set to make those two tabs available and visible, they will appear in the App as they did originally. 
Ken LewisKen Lewis
When I encountered this problem, I noticed that one of the deployment errors was related to the external sharing model:

"Can't specify an external sharing model for Fund__c"

This answer (https://salesforce.stackexchange.com/a/107447/4880) from Stack Exchange led me to compare the external sharing model settings in my scratch org and the Trailhead Playground Org.  Enabling the external sharing model (Setup --> Sharing Settings) in my TPO so that it aligned with the scratch org resolved the issue. 
Andrew WeinsteinAndrew Weinstein
i just ran into this same issue. Ken's solution worked for me - just "Enable External Sharing Model" in the playground.
David Grani 10David Grani 10
Same issue when using the playground, Ken's solution worked for me (Setup -> Sharing Settings -> Enable External Sharing Model)
Mark HansenMark Hansen
In my case, I notice the problem "property 'identifier' not valid in version 52.0 (9:32)".  It was caused by the fact that 'identifer' is introduced in version 53.0, but my scratch org got created in version 52.0.  I simply removed the 'identifier' elements from Fund_Explorer.flexipage-meta.xml and they the deployment worked.