+ Start a Discussion
Kenneth WangKenneth Wang 

API is not enabled for this Organization or Partner

Hi All,

I registered an account with https://www.salesforce.com/form/signup/freetrial-sales-ee.jsp. I can log in via browser but can not log in via api. It reports "API_DISABLED_FOR_ORG: This organization or partner does not have API enabled".

I did some research, some say that need to enable API Access, but I can not find this option in my account. Does anyone know how to set it on a trial account?

Others say it depends on the type of account, and only some of the types of accounts are enabled API Access, such as development. Does anyone know where the related documents are?

Thanks very much!!!
Best Answer chosen by Kenneth Wang
Rahul KumarRahul Kumar (Salesforce Developers) 
Hi Kenneth,

API is not enabled for this Organization or Partner" indicates that you're trying to do an API call and don't have API enabled. Here's how to fix that.

Resolution
1. First, check on the organization settings. Enterprise, Unlimited and Developer editions has the API enabled by default. Professional Customers can purchase this feature.
2. Check on the profile for the user. Access the profile settings in order to verify that API is enabled as well.
A. Click Setup | Administration Setup | Manage Users | Profiles.
B. Select the profile that you need to check, and under "Administrative Permissions" verify if API Enabled is checked.

Please refer the below link for reference. Please mark it as best answer if the information is informative.so that question is removed from an unanswered question and appear as a proper solution.

Thanks
Rahul Kumar

All Answers

Rahul KumarRahul Kumar (Salesforce Developers) 
Hi Kenneth,

API is not enabled for this Organization or Partner" indicates that you're trying to do an API call and don't have API enabled. Here's how to fix that.

Resolution
1. First, check on the organization settings. Enterprise, Unlimited and Developer editions has the API enabled by default. Professional Customers can purchase this feature.
2. Check on the profile for the user. Access the profile settings in order to verify that API is enabled as well.
A. Click Setup | Administration Setup | Manage Users | Profiles.
B. Select the profile that you need to check, and under "Administrative Permissions" verify if API Enabled is checked.

Please refer the below link for reference. Please mark it as best answer if the information is informative.so that question is removed from an unanswered question and appear as a proper solution.

Thanks
Rahul Kumar
This was selected as the best answer
Chintan Shah 116Chintan Shah 116
Hello,
I am receive the similar error message while creating a Force.com project. 

The edition that has been used is Developer Edition. 

The error message that i get is

"API is not enabled for this Organization or Partner"

Leveraged about sets however I cannot locate  Administration Setup | Manage Users | Profiles under setup.