+ Start a Discussion
Joan PowellJoan Powell 

Can't map in Trailhead Data Import Wizard

Trying to complete Data Import challenge - I go to Map, but I can't scroll all the way down the box to find/click "Map" button.  I'm on Chrome.  Tried switching to IE, that's not going to be supported by SF in a month and I can't get to the "Map" button there either.  HELP!!!

User-added image
Maharajan CMaharajan C
Hi Joan,

I think you are using the Salesforce lightning.

So try this by switch back to Salesforce Classic and launch the Import wizard.

Data Import wizards looks exactly like Lightning in Salesforce Classic also.

Can you please Let me know if it works or not!!!

If it helps don't forget to mark this as a best answer!!!

Joreal Whitfield 9Joreal Whitfield 9
Great tip Maharajan! Saved me a few hours of troubleshooting :)
David So 3David So 3
Then why did Salesforce indicated in the module to use Lightning?
User-added image
陳蕙心 Cymbi Chen陳蕙心 Cymbi Chen
I have the same problem in Lightning. Tried Chrome and Safari, both have the same problem. Finished the challenge in classic, though.
This is a Lightning UI problem happend when Salesforce indicated in the module to use Lightning. So interesting....
Stamen Nikolov 4Stamen Nikolov 4
Hi all,

I`m having troubles with this Trailhead module for Data Import Wizard - https://trailhead.salesforce.com/projects/import-and-export-with-data-management-tools/steps/use-the-data-import-wizard?trailmix_creator_id=00550000006yDdKAAU&trailmix_id=prepare-for-your-salesforce-advanced-administrator-credential

I`m following the instructions, downloading the file, setting up the DIW as it`s requested and when I go to the mapping it shows me the fields all in one row instead of showing the fields in separate rows. I tried severals ways for mapping, tried classic and lightning and I got several unsuccessfull imports already. Does any of you have an idea why do I get this? Thank you!

User-added image
陳蕙心 Cymbi Chen陳蕙心 Cymbi Chen
Hey guys, there's some fixes I came up with my colleague:

For people who can't find the button: 
Try this: zoom out (adjust the size to 90% or even 75%), then the buttom will show up.
Why: This is a page/html layout bug that SFDC should be fix.

For people can't get correct match in import:
Try this: check the font, typo or any punctuation/annotation error.
Why: Import wizard has very knowledge about punctuation, there for we human have to do the spelling check.

If you find this reply useful, please upvote to let others know it's working.
Stamen Nikolov 4Stamen Nikolov 4
After some time of investigating I found that for my issue where I see all fields in one line I have to adjust the file before the import to make it readable. Haven't really tried that yet, but basically you have to find the right delimiter so the Data Import Wizard read the columns (fields) as different rows.
Divya VasudevanDivya Vasudevan
Hi Cymbi,

Perfect , Your first solution worked .. I was stuck on that mapping for 30 minutes.. You saved my time.. Many thanks 
Randy GuzmanRandy Guzman
OMG. The little things...thanks Maharajan!!
Audrey-Diane Perrier-BizeauAudrey-Diane Perrier-Bizeau
Hey guys,

I have the same problem as Stamen I think, all my fields are in 1 line and I can't find how to split it, so i could do the mapping.

Could you please help me ?

Thanks :)

User-added image
Stamen Nikolov 4Stamen Nikolov 4

After few months dealing with Data Migration on big project and hundreds of files manipulated I got back AGAIN on this badge. And finally was able to figure out the problem. So I`d say there`s a time for everything and when we`re not ready, we`re not ready :)

Now straight to the problem and how you can workaround it:

I have found that issue comes from the default language/region settings on my PC. There you can define what would be the default delimiter. And even though the delimiter was showing as comma for me, it was still saving the csv files with semi-comma delimiter. You can check what is the delimiter when you open the file in a text editor like Note++. Now, how i fixed that - I did change the Format from my local country format to English(United States). Maybe for some of you it might be worth to first check under Additional settings if the delimiter is comma and if not to change it, save, restart and test. If it doesn`t work then go with changing the format to English(United States).
User-added image

You can find these setting under Control Panel > Region 

There`s also another option to workaround this Trailhead badge:
When you go through the steps of the Data Import Wizard maybe you have noticed that when you load the file there`s 2 options to select for file delimiter: Comma or Tab:
User-added imageUser-added image
You can simply open the originally downloaded import file in excel, do the adjustments and then save as Text(Tab separated) and chooce this Tab option in the import wizard.

Remain on your disposal for further questions!




Thanks for the solution Stamen! I had the same issue.
Nigel de la RambeljeNigel de la Rambelje
March 2020 I'm still running into the same errors as described above. The button to map is still not visible in Lightning so I switched to Classic where I did see the button and could map my fields, so many thanks @Maharajan C. 

And like @Stamen Nikolov 4 I saw all my field in a row instead as separate rows due to which my import kept running into errors. I checked my .csv in notepad and I saw that it was separated by semicolon instead of comma, just as Stamen described. I only had a test file consisting of four rows so I manually changed the semicolon to comma, saved it as .csv and ran my import again. And this time my headers were shown as separate rows and could run my import succesfully!

It does not belong in this thread, I know, but does anyone know why the succesfully imported records (according to the e-mail I received and the log report) are not shown as records in my custom object?
Nigel de la RambeljeNigel de la Rambelje
Apologies, forget my last question. I'm a total noob and wasn't aware that the default list view is set to 'recently viewed'... but just figured it out ;)
Jorge DaumenJorge Daumen
its 2020 and had the problem. Its the data. My mistake. I copied into an excel and saved as CSV. I should have just done what the instructions said to right click and save as CSV. They sound the same, but some issue must have come up in doing the copy/paste. You know it works becuase you can map all 6 fields. In the bad file you could only map 1. 
Yasmeen BoulesYasmeen Boules
Hi you just need to less zoom the widow to 70% to can scroll and see the map button
Aakanksha AgarwalAakanksha Agarwal
Its 2021 and its the same issue. Not able to see the map button, after zooming in also.
Claudio BorromeiClaudio Borromei
Here an easy solution if you see all the data in one line.

Open the CSV file on a Text Edit app.
Search (Cmd + F on mac) semi-comma ";" and Replace with comma ","
Click on Replace All.
You have the file CSV ready to import and complete the exercise.

Vicente Cuenca HernandezVicente Cuenca Hernandez
I had the same problem with my csv (comma delimited), so I saved my file as a text (tab delimited) and used the "Values separated by... Tab" option to upload my file. That worked for me, so maybe you can try, too.
Jay ChengJay Cheng
this issue still persists after 4 years.   I tried it both in lighting and classic view, same issue.  Changed browser zoom to 90% in Chrome for classic and 80% in lightning and it worked.
Corinne CouanonCorinne Couanon
I had the same issue.Changing the zoomin to 70% in Lightning resolved the issue and I could complete the challenge !!!
Amine MeksemAmine Meksem
Hello guys,
If you have the same problem as Stamen I got you a solution that I just used.
If your issue is: "I go to the mapping it shows me the fields all in one row instead of showing the fields in separate rows"
The problem is: Your Excel file, (salesforce can't recognize somehow the delimiter you're using although it's clear smh)
The solution is: what I did was:
1- on the excel file I used this formula, (for the first row for example) =A1&","&B1&","&C1...etc and dragged the whole this on my list. With this I had everything comma separated.
2-Next copy and paste values (on a new excel file will be better), I insist on values otherwise you'll have an error message because you copied the formula.
3-Save the new excel file to a CSV file.
I spent the whole morning trying to figure out something because i have tried everything I had in mind and it made no sense why wouldn't it work (i know exactly how you feel), well now don't worry everything works fine.