+ Start a Discussion
Gillian BruceGillian Bruce 

Implement Flow with a custom button

I created the flow & custom button, and they both work. But Trailhead API isn't registering it. I've re-done the whole project twice in fresh dev orgs and still no luck. Any ideas? I cut & paste all entries to ensure no typos. 
error message
Custom button & updated fields from flow
Best Answer chosen by Gillian Bruce
NagendraNagendra (Salesforce Developers) 
Hi Gillian,

I had that issue too, and in my case, I assume the API was the same as the label, but they want the API to be Calculate_Discount_button instead of the default Calculate_Discount that auto fills. May I suggest you please give a try with the above solution which might probably resolve the issue.

Please let us know if this helps.

Thanks,
Nagendra.

All Answers

NagendraNagendra (Salesforce Developers) 
Hi Gillian,

I had that issue too, and in my case, I assume the API was the same as the label, but they want the API to be Calculate_Discount_button instead of the default Calculate_Discount that auto fills. May I suggest you please give a try with the above solution which might probably resolve the issue.

Please let us know if this helps.

Thanks,
Nagendra.
This was selected as the best answer
Gillian BruceGillian Bruce
You are right, Nagendra! I actually pinged the Trailhead team at Salesforce HQ & they confirmed what you wrote. I made that change and finally earned my badge :) Thanks so much!
NagendraNagendra (Salesforce Developers) 
Hi Gillian,

I'm glad that you have passed the challenge.

May I suggest you please mark this post as solved so that others may get benefitted.

Thanks,
Nagendra.
Claudio Bruno 8Claudio Bruno 8
Hi, the challenge take me this error: 

User-added image
Someone could help me?

Thanks in advance.