+ Start a Discussion
Alice Chen 33Alice Chen 33 

Mailchimp to Salesforce Integration error in Salesforce

Hi there,

I've started the integration between Mailchimp and Salesforce, and am stuck on the step where I need to connect my Mailchimp account to Salesforce (authentication step in Salesforce). 

However once I clicked into MC Setup page in Salesforce, it immediately popped up an error message:
User-added image

After going into "Remote Site Settings" like the error message suggested, what do I need to update/change to remove the error message, and continue with the integration process?

Thanks,
Alice 
Abhishek BansalAbhishek Bansal
Hi Alice,

This error is related to your Endpoint.
1. make sure Remote Site Settings is exactly the URL you want to call
2. make sure the outer URL is active
3. make sure you call this URL in the right way

Please try changing it to https://www. your complete URL

Let me know f you need any other help.

Thanks,
Abhishek Bansal.
AbhishekAbhishek (Salesforce Developers) 
Try the suggestions as mentioned in the below blogs,

https://stackoverflow.com/questions/24290617/unauthorized-endpoint-please-check-setup-security-remote-site-settings-endpoi

https://salesforce.stackexchange.com/questions/25703/unauthorized-endpoint-please-check-setup-security-remote-site-settings-endp


I hope you find the above information is helpful. If it does, please mark as Best Answer to help others too.

Thanks.
Alice Chen 33Alice Chen 33

Thank you for the tips!
I've gone pass that error message, and come to Step 3: Map fields. However I can't seem to change any of the fields. For example, when I try to map the Salesforce Lead Field to "Company" --> Mailchimp Field Company:
User-added image

The below error message pops up:
User-added image

I am a system admin in Salesforce, so not sure what user profile is required to map fields?

Many thanks,
Alice 

Abhishek BansalAbhishek Bansal
Hi Alice,

Please check the FLS for the fields on the object MC List. Make sure the fields you are trying to map should have edit rights for the admin.
Once that is done you will be able to map the fields:

Go to Setup -> Custom Objects -> MC List Object -> Go  to the fied that you want to map -> Click on Set Field Level Security button -> Make sure editable checkbox is checked for Admin profile -> Save

Let me know if you need more help on this.

Thanks,
Abhishek Bansal.
Alice Chen 33Alice Chen 33
Hi Abhishek, Thanks for the response! I can't seem to see the Custom Objects page in my Salesforce Setup dashboard. Would you mind showing me where to find it? Many thanks, Alice
Abhishek BansalAbhishek Bansal
Hi Alice,

Go to Setup -> Object Manager -> Find your object -> Go to Fields and Relationships -> Set the FLS for the fields.

You can aslo reach out to me for any immediate help.

Thanks,
Abhishek Bansal.
Gmail: abhibansal2790@gmail.com
Skype: abhishek.bansal2790
Phone: +917357512102
Alice Chen 33Alice Chen 33
Hi Abhishek, Thank you for the fast response! I can’t seem to find Object Manager in my Setup dashboard either, is there a screenshot you can share on where to click once I reach the Setup page? Many thanks, Alice
Abhishek BansalAbhishek Bansal
Please find the screenshot below:
User-added image
Alice Chen 33Alice Chen 33
Hi Abhishek, Thank you! I've manage to update the fields with your instructions. Although I didn't see a mapping option for "email" for Mailchimp, is that because it will auto sync with between Salesforce and Mailchimp without me setting up the fields in this step? Or I will need to add a new field in, to map the emails as well? Warm regards, Alice
Abhishek BansalAbhishek Bansal
Yes the field should exist and if not then please create a new field, you need to set up the mappings.
Alice Chen 33Alice Chen 33
Thank you Abhishek! I've setup the mapping field for email no problems, but once I click "Save" to go to the next step, it immediately brings me to the new error message: "Read" permission to field "MC4SF__MailChimp_Link__c" on object "MC4SF__MC_Campaign__c" is not allowed for the current user. Error is in expression '{!initPage}' in component in page mc4sf:setup: (MC4SF) [image: image.png] However I tried to use the same method you taught me previously to set field security level, I cannot find both of these fields in "Fields and Relationships". Are these nested in another place on Salesforce? How should proceed to get pass this error message? Many thanks, Alice
Abhishek BansalAbhishek Bansal
As per the error the fields should be available in the same object: MC4SF__MC_Campaign__c
Not sure why you are not able to find these fields. I need to look at your org to get the root cause. If possible please contact me on gmail or skype.
Alice Chen 33Alice Chen 33
Hi Abhishek, Thanks for your response, I've cc'ed this email trail to your gmail email as well. I don't have Skype, but happy to use Google Meet if that works for you? Warm regards, Alice