+ Start a Discussion
Mandodari RawatMandodari Rawat 

Unable to insert pick list values to Standard pick list field using REST tooling API.

If I run PATCH /services/data/v49.0/tooling/sobjects/StandardValueSet/Product2Family, I get an error: MALFORMED_ID: bad id Product2Family.
If I run
POST /services/data/v49.0/tooling/sobjects/StandardValueSet, I get an error: FIELD_INTEGRITY_EXCEPTION: insert isn't supported for the standard value set Product2Family.  
SwethaSwetha (Salesforce Developers) 
HI Mandodari,

Like mentioned in the post https://trailblazers.salesforce.com/answers?id=9064S000000Cs5WQAS , can you try with ANT and confirm if you succeed while I repro this from my end?Thanks
Mandodari Rawat 12Mandodari Rawat 12
Hi Swetha,
Using ANT tool I was able to add the new value to the picklist. My requirement is to do the job using REST tooling API.

SwethaSwetha (Salesforce Developers) 
I see that you have already logged a case with Salesforce support team (Case #27278928) and the Salesforce Product development team has confirmed that this is a bug with no workaround as of now. 

I am following the Bug and will post on this thread if I have an update from them.

Please mark this answer as best so that others facing the same issue will find this information useful. Thank you

Swetha Maddali
Salesforce Support
Senior Success Engineer Tier 2
Long Nguyen 19Long Nguyen 19
I was searching for same issue and finally found this. Do you know any other workaround instead of using ANT tool?
Mandodari RawatMandodari Rawat
Not yet. Waiting on Salesforce to fix this issue.