+ Start a Discussion

Apex Dataloader CLI with MS Access

Hi All,


I have successfully configured the dataloader to connect and insert data into an MS Access DB, however I am unable to extract information from the same DB.  When I attempt to read from the database I receive the following error:


3899 [accountUpsertProcess] ERROR com.salesforce.lexiloader.dao.database.DatabaseReader  - Database error encountered during setup of the database configuration: queryAccountAll.
Sql error: Invalid Fetch Size.
java.sql.SQLException: Invalid Fetch Size
        at sun.jdbc.odbc.JdbcOdbcStatement.setFetchSize(JdbcOdbcStatement.java:826)
        at org.apache.commons.dbcp.DelegatingStatement.setFetchSize(DelegatingStatement.java:276)
        at com.salesforce.lexiloader.dao.database.DatabaseReader.setupQuery(DatabaseReader.java:146)
        at com.salesforce.lexiloader.dao.database.DatabaseReader.open(DatabaseReader.java:115)
        at com.salesforce.lexiloader.dao.database.DatabaseReader.open(DatabaseReader.java:103)
        at com.salesforce.lexiloader.util.DAORowUtil.calculateTotalRows(DAORowUtil.java:59)
        at com.salesforce.lexiloader.dao.database.DatabaseReader.getTotalRows(DatabaseReader.java:214)
        at com.salesforce.lexiloader.action.AbstractLoadAction.<init>(AbstractLoadAction.java:90)
        at com.salesforce.lexiloader.action.BasePartnerLoadAction.<init>(BasePartnerLoadAction.java:44)
        at com.salesforce.lexiloader.action.UpsertAction.<init>(UpsertAction.java:47)
        at com.salesforce.lexiloader.action.ActionFactory.getActionInstance(ActionFactory.java:78)
        at com.salesforce.lexiloader.controller.Controller.executeAction(Controller.java:113)
        at com.salesforce.lexiloader.process.ProcessRunner.run(ProcessRunner.java:136)
        at com.salesforce.lexiloader.process.ProcessRunner.main(ProcessRunner.java:228)
3915 [accountUpsertProcess] ERROR com.salesforce.lexiloader.util.DAORowUtil  - Error Calculating Total Rows


Has anyone successfully configured a CLI process to extract data from Access?



It seems there is an issue with the fetch size!

Did you set the extract batch size parameter in process-conf.xml?



Yes, I set the dataAccess.readBatchSize within the process-conf.xml file to 50.

Sunil NandipatiSunil Nandipati
I am facing the same issue.  were u able to solve your problem?
Can you please send me the resource-conf files for inserting in to the Access

Was anyone able to resolve this issue?  If so, can you please post the solution - I've been searching for hours for an answer....

Jerun JoseJerun Jose



Could you please post the solution for this?


I'm having the same error and not sure on how to fix it.


Adding myself to the list ... anyone able to solve this?





Any solution..i am also facing the same error