+ Start a Discussion

Force.com IDE summer '08 broken on sandbox with Winter '09?

After the sandbox was updated to Winter '09 on September 19, the Summer '08 Force.com IDE has been unusable for me for Apex code development on both a Linux with Eclipse 3.2 and MacOS X with Eclipse 3.3.

Effectively, any change to a source file, including trivial changes, say to a comment, results in "Save error: invalid server id"

Tests do not run at all - no output in the Errors or Apex Test Code Runner tabs of the IDE.

Code may be edited in the Salesforce web app, and tests run there, but not being able to use the IDE makes deployment considerably less convenient.

I realise that there are some known issues surrounding this, but how widespread is the problem? I haven't found mention of it here on the boards, so I'm wondering if the bug is specific to only some orgs (which raises the question of why). Also, with the IDE going GA in a week, is there a release candidate of the IDE that addresses these issues?

Just hoping to learn more about the nature of this problem...


Winter '09 (on Sandbox or anywhere) should be backward-compatible with the Summer '08 Force.com IDE.  We will need to investigate the issues you're seeing.  Can you send me a private message with your Organization Id?

We are not providing early access to Winter '09 Force.com IDE release candidates, but its GA is only a few weeks away.

I'm having an issue that I believe is related to the Winter '09 upgrade as well.  I wrote a trigger in my sandbox environment and am trying to deploy it to production but I'm getting an UNKNOWN EXCEPTION error when I try to deploy it.  I get this when I deploy via eclipse or using the ANT tool.  Does anyone know if there's an update for the IDE for Winter '09?

The Force.com IDE for Winter '09 is scheduled for release on 10/27.

For your UNKNOWN_EXCEPTION issue, please open a support case so our developers will look into it.

It appears that this issue has been resolved sometime between Oct 9 and Oct 10. I can again save class files and run unit tests from the Force.com IDE 13.0. I'm hoping that someone did something somewhere, and it's not just a 'miracle', but as long as it's working, I'll take it.
We've been experiencing this same issue(s) with the Force.com IDE being unusable.
It looks as if one of our package.xml files are corrupt.  We cannot update any class file or trigger in this package (including trivial changes, say adding a comment), we receive similar error "Save error: invalid server id" related to the package xml file.  In addition, as you mentioned, the tests do not run at all - no output in the Errors or Apex Test Code Runner tabs of the IDE.
Based on this thread I've attempted to use the new Winter '09 Eclipse 3.3 (fresh install, fresh local Force.com project) however, we are still recieving the same error(s). 
I was able to remove a class file and a trigger file in this package from with Salesforce Sanbox web app, and I was able to refresh the package with the changes reflected in the Eclipse IDE.  However, when attempting to deploy to server to remove these same code files from production I again recieved a "Server error: invalid server id".
I can and will open a case with SFDC however, this seems like a known widespread issue?  Does anyone know when it will be addressed?  What method should we use to deploy code changes in the interim?

I have the same issue with the package.xml file

Whenever I try to save any changes to an existing trigger in this package, I get this error:

Save error: Cannot complete this operation. This custom object cannot have a Master-Detail field because of usages elsewhere in Salesforce. : Mobile Administration

I can modify the trigger directly in salesforce without any errors. I haven't tried deploying the changes to production yet, so I don't know if that is going to be a problem as well