+ Start a Discussion

Deploying a project using the Force.com IDE Eclipse - Spring'09

We have been trying 'desperately' to deploy our app from Sandbox to Production. Earlier in the week, we knew we could face problems as the Sandbox was in Spring'09 while Production was still Winter'09. During that phase, the Force.com IDE either just timed out or threw an error after a long time without any description.
Now that both Sandbox and Production are on Spring'09, we started getting Java Heap Size - Out Of Memory exceptions. We tried to increase the Heap Size but to no relief; it just wouldn't go.
We gave up using Eclipse and tried deploying with Ant. Thankfully, that showed us a few errors in our Test Methods which we corrected. But lo and behold,  now even Ant is timing out.
Is this something to do with Spring'09? Do we have to wait for the new IDE or Ant tool? What could be the reason for this? This is not only on one project or on a single location/machine. The deployment was tried on multiple systems in multiple countries and on 2 projects - one where the production server is on NA1 and another where it is NA6.
This is very crucial, important and urgent so any help would be beneficial.
Thank You! 


Please open a case with Salesforce Support on this immediately.


Also, I just emailed a link your post to the folks in charge of the Force.com IDE (Eclipse plugin), metadata API, and ant deploy to get things going inside of R&D.

Message Edited by dchasman on 02-08-2009 07:08 PM
Message Edited by dchasman on 02-08-2009 07:10 PM
Bill EidsonBill Eidson


  md1 -


  It sounds as if perhaps the tests are running long?  You can increase the timeouts within the ant tool.  I've sent you an offline email, if you could respond with your organization_id, I can check the logs to check on the status.




  - Bill



The Spring '09 server release is backward compatible with any version of the Force.com IDE.  I have used the Winter '09 IDE against Spring '09 many times, with no incidents.  So what is happening is either an obscure bug on the server that we will need to fix, or an Eclipse/Force.om IDE setting you will need to change.


If you have access to salesforce.com support, please open a case ASAP.

If not, please answer these questions so we can try to understand what's happening:

- What version of the Force.com IDE are you using? 

- How much memory are you allocating to Eclipse?  See this note.

- Do you see any exceptions in the console log or the Force.com IDE log (Help > Show Force.com IDE Log)?





salesforce.com Product Manager