function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Salesforce, Snow White and the Seven Dwarfs

Hi guys,


today I received a strange error message after trying to change the controller in the visualforce editor


Error: java.sql.SQLException: ORA-00001: unique constraint (CORE.AKAPEX_CLASS) violated ORA-06512: at "HAPPY.CAPEX", line 505 ORA-06512: at line 1 : {call cApex.update_class(?,?,?,?,?,?,?,?,?,?,?,?)})} 



and remebered about a Blog article on Wes's Blog about strange error messages where I found this



Error: java.sql.SQLException: ORA-00001: unique constraint (CORE.AKAPEX_CLASS) violated ORA-06512: at “SNEEZY.CAPEX”, line 505 ORA-06512: at line 1 : {call cApex.update_class(?,?,?,?,?,?,?,?,?,?,?,?)})} 




Looks like some SF guys are huge fans 'Snow White and the Seven Dwarfs' .



So the big question is, where are the others and of course where's Snow White?





I noticed this as well.
They are currently on Dopey:

"DOPEY.ROWLOCK", line 60 

Darrell DeanDarrell Dean

Yeah, I got GRUMPY!


While a user is trying to save a cloned opportunity - java.sql.SQLException: ORA-20067: ORA-06512: at "GRUMPY.GUTIL", line 42 ORA-06512: at "GRUMPY.SOPPLINEITEM", line 696 ORA-06512: at line 1


Anyone have any help? I have googled it and am not finding any.

I got HAPPY!

Did anyone got the solution for this? ORA-20001: ORA-06512: at "HAPPY.SACCESS", line


I copied code to a class, while saving it shows this error:

Error: common.exception.SqlDupValOnIndexException: ORA-00001: unique constraint (CORE.AK2APEX_CLASS) violated ORA-06512: at "SNEEZY.CAPEX", line 1003 ORA-06512: at line 1 {call cApex.update_class(?,?,?,?,?,?,?,?,?,?,?,?,?,?,?)} {call cApex.update_class(?,?,?,?,?,?,?,?,?,?,?,?,?,?,?)}

Ray Zhao 3Ray Zhao 3
I got DOPEY!

Seems like there is no one given any answers yet.  I will update this if I can get my error resolved!
common.exception.Sfdc.SqlException: ORA-20119: ORA-06512: at “DOPEY.CPRICEBOOKENTRY”, line 594 ORA-00001: unique constraint (CORE.AKPRICEBOOK_ENTRY) violated ORA-06512: at line 1 {call cPricebookEntry.insert_pricebookentries(?,?,?,?,?,?,?,?,?,?,?,?,?)} {call cPricebookEntry.insert_pricebookentries(?,?,?,?,?,?,?,?,?,?,?,?,?)}
Abhishek MahajanAbhishek Mahajan
I got Doc!

The error was because I used Database,leadConvert in Lead AfterInsert trigger.

Reason: Your Prospect could not be processed.
common.exception.SfdcSqlException: ORA-20025:
ORA-06512: at "DOC.CACCESS", line 2420
ORA-06512: at "DOC.CACCESS", line 585
ORA-06512: at "DOC.CACCESS", line 656
ORA-06512: at "DOC.CTASK", line 546
ORA-06512: at line 1

Fortunately, I got rid of it by moving my whole lead conversion logic from after Insert trigger to a queuable class.
Angelo Rivera 1029Angelo Rivera 1029
09:34:35.713 (1765488690)|VALIDATION_ERROR|Validation Formula "Validate_No_Data_Consignment" Invalid (ORA-20001: 
ORA-06512: at "DOPEY.CMETAACCESS", line 553
ORA-01403: no data found
ORA-06512: at "DOPEY.CMETAACCESS", line 732
ORA-06512: at "DOPEY.CMETAACCESS", line 718
ORA-06512: at "DOPEY.CMETAACCESS", line 683
ORA-06512: at "DOPEY.CGROUP", line 1217
ORA-06512: at line 1

{call cGroup.get_group(?,?)}

{call cGroup.get_group(?,?)})
Dennis H PalmerDennis H Palmer
Error: Invalid Data. 
Review all error messages below to correct your data.
common.exception.SfdcSqlException: ORA-20119: ORA-06512: at "GRUMPY.CPRICEBOOKENTRY", line 744 ORA-00001: unique constraint (CORE.AKPRICEBOOK_ENTRY) violated ORA-06512: at line 1 {call cPricebookEntry.insert_pricebookentries(?,?,?,?,?,?,?,?,?,?)} {call cPricebookEntry.insert_pricebookentries(?,?,?,?,?,?,?,?,?,?)}
Khushbu Agarwal 8Khushbu Agarwal 8
HI all,

Anyone can help me resolve this issue. Appreciate it.

common.exception.SfdcSqlException: ORA-00060: deadlock detected while waiting for resource ORA-06512: at "DOPEY.CAPICURSOR", line 204 ORA-06512: at line 1
Dennis H PalmerDennis H Palmer
Hey Khushbu,

These errors should be reported to SFDC by opening a case with them.  I haven't found much in the way of how to resolve these as they are errors that bubble up from the underlying database (Oracle), which in theory, should never happen.  Open a case with SFDC.
Steve BerleySteve Berley
I got Sneezy over the weekend.   Now I need to collect the whole set.
[object Object]: ORA-20001: ORA-06512: at "SNEEZY.SACCESS", line 930 ORA-01403: no data found ORA-06512: at "SNEEZY.CACCESS", line 3212 ORA-06512: at "SNEEZY.CACCESS", line 2902 ORA-06512: at line 1 SQLException while executing plsql statement: {call cAccess.check_entity_access_proc_ncu(?,?,?,?,?,?)}(EXCLUDED, EXCLUDED, 003f4000007Ymd7, EXCLUDED, true, false)

Tyler McCartyTyler McCarty
I'm not sure what causes this error but we were getting this error in a sandbox while trying to update a field on Opportunity. It was giving the SNEEZY,BACCESS error. We were able to resolve this by adding a Contact record to the Opportunity. Maybe something to do with a Lookup field being Null while trying to do a DML statement. Not sure, Contact isn't required, neither was the field we were trying to update. Even when trying to clone the associated record it was giving Contact__c id does not exist: null. So maybe try to clone the record and see if it will say the field that is causing the issue
Michael Smith 35Michael Smith 35
Had this issue (DOPEY.SACCESS) when trying to edit an account, read the comments here and @Tyler McCarty's suggestion worked. I tried to clone the record and it told me the Parent ID was not valid. Cleared the field value and then was able to save. I think the parent relationship had been removed but on the backend, it still had a value.