+ Start a Discussion
arnaud c.ax1343arnaud c.ax1343 

Its too hard to install Force.com IDE correctly for a beginner developer

I tried installing the force.com ide standalone installer but its just a waste of time and does not work properly. I have spent more than half a day trying to get this right and i have had to abandon this as its just not productive. I have hit 3 different errors from installation to trying to get a project up and editing its contents or syncing to the server.


here are the 3 errors encountered. Currently only 1 remains that i just dont have the courage to fix now.


1. java.lang.runtimeexception: application "" could not be found in the registry force


this error happened after installing force.com ide. I found that i needed to change the config file to get it working


2. com.salesforce.ide.aip.metadata.types.Metadata$JaxbAccessorF_fullName cannot be cast to com.sun.xml.Internal.bind.v2.runtime.reflect.Accessor


this happened after i upgraded the force.com ide i think and i had to add -clean to another .ini file so the force.com ide could boot properly to the workspace


3. same error as 2 but now i am trying to add/remove components to a project i have created but that does not work. Trying to look at existing project components also throws an error.



All i want to do is try using the force.com ide to follow the developer training course but i think i would be just better off doing the inline apex editing and hope to save before hitting Backspace accidentally on the browser page and loosing all edited code after the last Quick Save.


Does anyone know a 100% sure way of getting force.com ide to work without having to troubleshoot this stuff every 10 minutes?






Try just installiing Eclise stand alone and then add the Force.com plug-in seperatley. All else fails......switch to a Mac : )




arnaud c.ax1343arnaud c.ax1343

Thanks for the response. So it seems that we shouldn't even bother trying the standalone version. Probably we should have that removed from the main page then.


As for the suggestion to go Mac: i'd prefer to reboot my old Commodore 64 and load code from a cassette tape, rather than use any Apple tech.


but thanks for the advice :)