+ Start a Discussion

S-control problem


All of a sudden my S-control started giving "Insufficient privileges" error message , even though I am the administrator.
Did any thing chane regarding the S-control ?

I am actually displaying the S-control using the following code

<apex:tab label="WhiteBoard" name="WhiteBoard" id="tabWB">
<apex:scontrol controlname="Whitecanvas" subject="Whitecanvas" width="800" height="600"/>




When I removed " subject " from the

<apex:scontrol controlName="Whitecanvas" subject="Whitecanvas" width="800" height="600"/>

it is working. I donno the exact reason but it worked till yesterday . I actually shd not specify "subject" field since no object is supplying any data to this s-control. I wonder how it worked all these days :smileyindifferent:

The constant value of Whitecanvas for your subject does not make any sense, straight from the Component Reference:

subjectObjectThe ID of the record that should provide data for this s-control.

this is typically meant to be an value binding expression like {!account.id}.

Message Edited by dchasman on 06-14-2008 06:31 PM