+ Start a Discussion
bihasabihasa 

データローダで日付型のデータをInsertすると日付がづれる事がある

データローダのバージョン23.0を使って、日付型の項目(日時型ではありません)をInsertすると日付が一日戻る事があります。

Insertするcsvデータは「10/01/2011」としているのに、実際にSalesforceに作成されたデータを見に行くと「09/30/2011」になってしまいます。

 

今まで、バージョン18.0を使っていてこんなことはなかったのですが、何かの設定を修正することで対応が可能なのでしょうか。

また旧バージョンのデータローダを入手可能かについても、ご存知の方がいらっしゃれば教えて頂きたいです。

 

以上、よろしくお願いします。

Best Answer chosen by Admin (Salesforce Developers) 
kamekame

Ver20くらいから、DataLoaderの設定画面(Settings)で、タイムゾーンを設定する個所が増えました。ここがおそらく「TOKYO」とかになっていると思います。インストールすると、デフォルトが「TOKYO」になってしまうようです。

タイムゾーンの設定を「GMT」にすることで、1日戻ることはなくなると思います。

All Answers

ikouikou
bihasabihasa

ikouさん

 

ご返信ありがとうございます。

参考になりました。一日前の情報が適用されるのが標準なんですね。恥ずかしながら初めて知りました。

 

ただ、不可解なのですが、DataloaderのVer18.0を私のPCで使っている分には一日前の情報になることは過去に一度もなく、

他のPCからDateloaderのVer23.0を使ってInsertを実行すると、一日前の情報になって反映さえる事が発生します。

(他のPCを使った場合も必ず一日前になるというわけではなく、そのままの日付が反映される事もあります。)

 

さらに先ほど、旧verのDateloaderを配布しているところを見つけて、他のPCに18.0をインストールしInsertを実行したら、

今後は必ず一日前に情報が反映されるようになりました。(ikouさんに共有頂いた情報通りになりました)

 

OSはWIn Xpで、私のPCも他のPCも同じです。

一体なんの違いによってこの様な違い生じるのか見当が付かず困っています。

なにかこの様な症状が発生する原因について、思い当たる事ある方がいらっしゃっいましたらご助言いただきたいと思います。

よろしくお願いします。

 

kamekame

Ver20くらいから、DataLoaderの設定画面(Settings)で、タイムゾーンを設定する個所が増えました。ここがおそらく「TOKYO」とかになっていると思います。インストールすると、デフォルトが「TOKYO」になってしまうようです。

タイムゾーンの設定を「GMT」にすることで、1日戻ることはなくなると思います。

This was selected as the best answer
bihasabihasa

kameさん

 

情報共有ありがとうございます。

TImezoneを「GMT」に設定したところ症状が解消しました。

取り急ぎ、ver23.0を使って対応しようと思います。

本当にありがとうございました。

 

ただ、ver18で症状が一日前になったりならなかったりするのは謎ですね…。