+ Start a Discussion
Mike DelGaudioMike DelGaudio 

OSX: Force.com IDE Open Perspective does not appear

Does anyone have any suggestions to get the Force.com perspective option to appear in Eclipse -- ON OSX Mavericks? 

I installed eclipse, dragged it to Applications, and an able to open it. 
I have followed the instructions here to install the Force.com IDE :https://developer.salesforce.com/page/Force.com_IDE_Installation

I have searched, and all the articles, answered questions say to edit eclipse.ini to add an expicit path the the JRE. I've been unable to locate eclipse.ini on OSX. There is a config.ini, but I cannot find a line in that file that appears to be appropriate to edit. 

I have tried Eclipse 4.2 and 4.3, and tried JRE 7, and JRE 8. 

Eclipse-> About Eclipse->Installation Details  shows that Force.com IDE is installed: "Force.com IDE 31.0.0.201406301722 com.salesforce.ide.feature.feature.group salesforce.com'

I cannot open a Force.com project, and the Perspective is not available as a choice. 
Best Answer chosen by Mike DelGaudio
Mike DelGaudioMike DelGaudio

That really helped, Avilion, I think I got it!

I figured it out, and it did have to do with the Java Version. The Instructions on the Force.com page indicate that you need the Java Runtime Environment, which -- silly me -- thought that meant the Java JRE... It doesn't. You need to download and install the Java JDK. The one I downloaded and installed was called "jdk-7u60-macosx-x64.dmg" from this page: http://www.oracle.com/technetwork/java/javase/downloads/jdk7-downloads-1880260.html

As it turns out, it looks like if you install the Java 7 JRE (not the JDK) it somehow invalidates the Java 6 JDK that may already be on your system. So I could see the Java 6 jdk, and eclipse could find it, but the Force.com bits wouldn't work. 

So, if you'd made that same mistake, you may need to tell eclipse that there's a new JDK on your system. 

Go to Eclipse->Preferences. IN the preference page use the quick find to search for "Java", then scroll the left panel to "Installed JRE's"

On the right, click "Search" and hopefully, eclipse will find your new JDK / JRE installation. Check the new one as the default, and restart eclipse.

Two JDK locations

That's how I did it, anyway. 

 

All Answers

AshwaniAshwani
Did you checked in:
Window > Open Prespective > Other | Select "Force.com"

By default Force.com doesn't have perspective open. 

Mike DelGaudioMike DelGaudio
Yes tried that per the instructions, thanks for the quick reply. It is not available under Other. Here is what I see:
No Force.com option in Other Perspective.
AshwaniAshwani
It means that there is issue with your installation. I have installed IDE with eclipse luna and Force.com wsa there. You should try unistalling the existing installation and installing again by Window > Install New Software...
Mike DelGaudioMike DelGaudio
Thanks for your continued assistance! I've tried both Juno and Kepler, and reinstalled the Force.com IDE packages on both. May I ask which installation of Luna are you using? Is it the Cocoa 32bit or Cocoa 64 bit, and which Edition of Eclipse Luna? (as in Eclipse Standard, or Eclipse IDE for Java Developers etc...) ... Finally, it appears that the Java JRE might matter. Do you know which JRE you have installed? 
I've tried the Java 7 JRE (here: http://www.oracle.com/technetwork/java/javase/downloads/java-se-jre-7-download-432155.html) and the Java 8 JRE( form here: http://www.oracle.com/technetwork/java/javase/downloads/index.html)

Any information that you can provide about your configuration would be appreciated. 

AshwaniAshwani
Hi Mike,

I am using Cocoa 64 bit installation and Eclipse Jee edition which is approximate 257 MB. Java JRE version is 6 in my machine.
Mike DelGaudioMike DelGaudio

That really helped, Avilion, I think I got it!

I figured it out, and it did have to do with the Java Version. The Instructions on the Force.com page indicate that you need the Java Runtime Environment, which -- silly me -- thought that meant the Java JRE... It doesn't. You need to download and install the Java JDK. The one I downloaded and installed was called "jdk-7u60-macosx-x64.dmg" from this page: http://www.oracle.com/technetwork/java/javase/downloads/jdk7-downloads-1880260.html

As it turns out, it looks like if you install the Java 7 JRE (not the JDK) it somehow invalidates the Java 6 JDK that may already be on your system. So I could see the Java 6 jdk, and eclipse could find it, but the Force.com bits wouldn't work. 

So, if you'd made that same mistake, you may need to tell eclipse that there's a new JDK on your system. 

Go to Eclipse->Preferences. IN the preference page use the quick find to search for "Java", then scroll the left panel to "Installed JRE's"

On the right, click "Search" and hopefully, eclipse will find your new JDK / JRE installation. Check the new one as the default, and restart eclipse.

Two JDK locations

That's how I did it, anyway. 

 

This was selected as the best answer
Marc BazinMarc Bazin
Hi Mike,
I follow the post flog as the solution and I still not see the force.com perspective.
the Force.com perspective does not appear on OSX. Even After installing JDK 7 and modifying JRE install in Eclipse.
Is anything else to change to have that working?





SFDC coderSFDC coder
thanks mike this really helped solve my issue..:)
rm18rm18
Hello,

The issue is the same my mac is OSx 10.10 Yosemite which accepts only java se 7 or higher so i downloaded java se 8 and also installed eclipse luna 64 bit coz eclipse kepler and helios i tried to install they need java se6  not se8 so further i tried to install force.com plugin which installed successfully as i can check from about eclipse>installation details> force.com ide v31 is installed but when i check from perspective it doesn't show up. please help me to resolve this issue asap...Appreciate your help!
rm18rm18
i tried to re install plugin, restart eclipse and check in perspective still force.com ide not found 
rm18rm18
and in the add repository> the location used to fill up automatically in past and now its empty i need to manually enter the url for force.com ide to download from internet into eclipse luna.
Laurence C.Laurence C.
I tried the solution here and Force.com perspective still wasn't showing up on MacOSx Mavericks (10.9.5), JDK 7, and Eclipse 4.2 (Juno).

In summary, this is what worked for me:
Adding a reference to the jdk into the eclipse.ini did the trick for me (see below) to force Eclipse to use the jdk when starting up. For some reason, even though I selected the appropriate JDK as stated by Mike DelGaudio's solution, force.com perspective still wasn't available. The key here is to make sure you use a JDK for Eclipse.

Detailed steps I took, which worked:
1. Close Eclipse
2. Open Terminal and execute the following on the shell:
 /usr/libexec/java_home 

You will get something like (this maybe different depending on which JDK version you installed - but JDK 7 worked for me):
/Library/Java/JavaVirtualMachines/jdk1.7.0_75.jdk/Contents/Home

3.  Edit the eclipse.ini  and point to the appropriate JDK path from step 2.
Instructions on how to edit eclipse.ini here: http://wiki.eclipse.org/Eclipse.ini#-vm_value:_Mac_OS_X_Example

For me, I added the following to the end of my eclipse.ini file:
-vm
/Library/Java/JavaVirtualMachines/jdk1.7.0_75.jdk/Contents/Home/bin/java

4. Install Force.com IDE as per normal (I installed version 31)


~~~~~~~~~~
My eclipse.ini looked like the following (don't copy and paste the whole thing - only pay attention to the last two lines starting with -vm:
~~~~~~~~~~
-startup
../../../plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
--launcher.library
../../../plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.200.v20120913-144807
-product
org.eclipse.epp.package.java.product
--launcher.defaultAction
openFile
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
-vm
/Library/Java/JavaVirtualMachines/jdk1.7.0_75.jdk/Contents/Home/bin/java
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Dhelp.lucene.tokenizer=standard
-XstartOnFirstThread
-Dorg.eclipse.swt.internal.carbon.smallFonts
-XX:MaxPermSize=512m
-Xms512m
-Xmx1024m
-Xdock:icon=../Resources/Eclipse.icns
-XstartOnFirstThread
-Dorg.eclipse.swt.internal.carbon.smallFonts
-vm
/Library/Java/JavaVirtualMachines/jdk1.7.0_75.jdk/Contents/Home/bin/java