+ Start a Discussion

Pie chart in report section without any count

I added a pie chart to the report.
But i am not able to see the record cout, it just show different color
Best Answer chosen by Sandrine
James LoghryJames Loghry
By default, dashbards don't have a record count functionality.  The do have a percent functionality though, that you can use to show the portion of a wedge in a pie chart.

To show this, you would edit the pie chart, click on the Formatting tab, and then make sure the "Show %" checkbox is checked.

Image 1

If the percent still doesn't work for you, you can add the record count to your pie chart by modifying the source report to include a "Row Count" summary formula field.

Image 2

Image 3
  1. In the report's Fields pane on the left, click on "Add Formula" and drag it onto your report.
  2. Give the formula a name.
  3. Select "Record Count" from the Summary Fields drop down above the Formula box (See 2nd image above)
  4. Click OK.  You should see the formula listed on the bottom of your report as a summarized value of record counts.
  5. Save the report and go back and edit your pie chart component.
  6. In the "Component Data" tab in your pie chart, select the Record or Row count formula field as the Values drop down (See 3rd image above)
  7. In the "Formatting" tab in your pie chart, make sure the Show values checkbox is checked.
  8. Save your chart and refresh the dashboard.

Hopefully that helps!