+ Start a Discussion
Joan HochJoan Hoch 

Unable to create Guest Admin in test on Trailhead Module

I'm unable to create a guest admin as part of the exercises in the Data Security module in Trailhead.  The license and related profile simply are not in dropdowns when adding new user,although the required sys admin profile actually exists in my developer edition.  How did people get around this? (PS - I'm in Data Security Module / Controlling Access to the Organization)
Best Answer chosen by Joan Hoch
Amit Chaudhary 8Amit Chaudhary 8
Please try to deactive other System admin user and then try to create new System admin user.

In Developer org you can create only 2 or 3 active user only.

Please let us know if this will help u

Thanks
Amit Chaudhary

All Answers

Amit Chaudhary 8Amit Chaudhary 8
Please try to deactive other System admin user and then try to create new System admin user.

In Developer org you can create only 2 or 3 active user only.

Please let us know if this will help u

Thanks
Amit Chaudhary
This was selected as the best answer
Joan HochJoan Hoch
I'm the only other system administrator, so it doesn't make sense to deactivate myself in DE.  Also, I've attempted this again, but now when trying to create a new user, it won't even let me deselect the 'active' checkbox to create a new user that is in inactive status.  Is this by design or an additional problem.
Amit Chaudhary 8Amit Chaudhary 8
Please check how many user you have in your org. Try to deactivate other and try again
Harikrishnan RamadassHarikrishnan Ramadass
I have the same issue too. Not able to create a new user with guestadmin username under system admin profile. I'm the only sysadmin and there are only 2 other users in my org. The dropdown has no option listed as system admin. Is there an issue with the design?
Amit Chaudhary 8Amit Chaudhary 8
Try to deactivate the other user and then try to create the new user. Please let us know if this will help u
Harikrishnan RamadassHarikrishnan Ramadass
Thanks, it worked!! 
Amit Chaudhary 8Amit Chaudhary 8
Ohh Grt Harikrishnan Ramadass. I am glad my solution helps you.

Hi Joan Hoch,

Please let us know if above solution helps you. Please mark the best answer if any comment helps you So that some one has issue that post can help Others

Thanks
Amit Chaudhary
L3nL3n
Hi, I am also trying to create a Guest systems admin. The drop down only shows: work.com only user. When I deactivate my other uer: chatter expert. I'm still unable to select the system admin profile.
Please help!
Lena
L3nL3n
Never mind, you have to select the User License as: Salesforce.
Nishant BeenuNishant Beenu
I have selected User License as : Saledforce.However, still not working
L3nL3n
What does it show for you? Did you try to deactivate the chatter expert?
Nishant BeenuNishant Beenu
Hi Lena

Yes, I have deactivated chatter expert profile. I have two profiles only 1st - My profile 2nd - Guest Admin

Below error message I am still getting.

Challenge not yet complete... here's what's wrong: 
An inactive user with 'guestadmin' in the username was not found. Make sure that the user is inactive and that the Username includes the 'guestadmin' string
L3nL3n
I mean what does the dropdown menu show for you, if it doesn't show Guest systems admin? You have a developer account right? Did you do all the items in the error message?
Dinesh K 17Dinesh K 17
Unable to view new users created with System administrator profile.

Solution:

"guestadmin" should be in username(ex: guestadmin@gmail.com) not as an Firstrname or Lastname.

tryout this and you can pass the challange.
Rima MukherjeeRima Mukherjee
Make sure you have the active button unchecked!!
 
Jayanth ThathapudiJayanth Thathapudi
My problem got resolved by following the below steps:

1.manage users->users->then select "All users"
2.I think developer edition can have atmost 4  Active Users . So deactive "Chatter Expert" user .
3.Now create a new user with username that contains "guestadmin@something.com"





 
Pooja KabraPooja Kabra
The error is duplicate username.The username already exists in this or another Salesforce organization. Usernames must be unique across all Salesforce organizations. To resolve, use a different username (it doesn't need to match the user's email address).
Ruxandra GrosuRuxandra Grosu
Hello. i seem to have the same issue. 

Error: Duplicate Username.
The username already exists in this or another Salesforce organization. Usernames must be unique across all Salesforce organizations. To resolve, use a different username (it doesn't need to match the user's email address).

cannot save the username under guestadmin and also cannot deactivate the current system admin on trailhead playground, which is also me.

please advise.

thanks.
Rizwan Ali 8Rizwan Ali 8
Challenge not yet complete in My Trailhead Playground 1
An inactive user with 'guestadmin' in the username was not found. Make sure that the user is inactive and that the Username includes the 'guestadmin' string

I GOT THIS PROBELM 
Please Help ?
Chetan TirthaniChetan Tirthani
Try to use <...guestadmin...>@<orgname of your TP> . You can copy the org name from your own sysadmin userid. 
Christian Alviar 8Christian Alviar 8
Why don't I have the "salesforce" option on my drop down for user license? It's showing that I only have a "salesforce platform"  user license so I cant finish the challenge. Help please. Thanks! 

User-added image
SakethSaketh
Hi Christian Alviar 8, 

Try doing below steps:

-> Create & Launch a new Playground
-> Create a user with systemadmin profile and Deactivate it.
OR
-> Try to Deactivate any of the users in the Org that you are using and then try to create a new user again.

Then you would see UserLicense  " Salesforce"

Thanks
 
Pabbas93Pabbas93
For many users, even though they are making it correctly, it is throwing the error becuase, users are executing it in lightning mode. try to check the challenge by changing the mode to classic. Hope this really work.
Tadeu Vaccari 2Tadeu Vaccari 2
Hello, please can some one clarify me how to deactivat a user? I created the new user System Admin with the 'guestadmin' string, but the I cannot deactivate the ohter Admin or ether chage its Username! what am I dont wrong?
Satomi TsutsuiSatomi Tsutsui
Hello, I also have a problem with creating ''guestadmin'' account and it shows ''The username already exists in this or another Salesforce organization. Usernames must be unique across all Salesforce organizations. To resolve, use a different username (it doesn't need to match the user's email address).''. I saw tips from previous people and tried to inactive all others but it showed looks like default and coundnt inactive these.
sampath tudganisampath tudgani
Hello, Please help still unable to pass this challenge

Followed all the suggested steps but still no luck.

There is already one System Administrator profile by default which cannot be made inactive and is it due to this that is causing the issue.

Please help.
 
Christopher MootooChristopher Mootoo
Hello,
In the list of users that appears, some of them are created in demo(example : Garza, Laura).
Locate the ones that are active and click "Edit". Check their licences, some will have "Salesforce".
Assign a new licence to that user "SalesforceForm" for example and save.
Now you have another "Salesforce" licence available and you can create the one asked in the challenge.
Renan LeitãoRenan Leitão
"
Kamila Peres Rocha (--)
Opa, consegui resolver esse mesmo problema agora. Foi um erro de tradução do próprio Trailhead, para resolver você vai ter que criar um novo perfil chamado "Administrador de sistema". É preciso criar um novo perfil porque o perfil existente que nós estávamos tentando usar para esse desafio foi traduzido como "Administrador do sistema" em vez de "Administrador de sistema", esse problema todo por causa da palavra "de" em vez de "do". rs
"