+ Start a Discussion
Tom Coffey 4Tom Coffey 4 

Deployment Error: Picklist value in picklist not found

I'm trying to deploy a package to a scratch org via the SFDX CLI using the sfdx force:mdapi:deploy command. 

See screenshot below for exact error message.

I have a "Reinsurer" picklist value on the Account object's Type field that I believe is causing the error.

I've done some research and found two others with a similar error:  
(1) was a version conflict issue and changing the version in package.xml fixed this.  My package.xml shows version 46.0.  Would changing my version fix this?  If so, what version should I use?
(2) Suggestion was to "include same picklist in change set while deployment".  I'm not using change sets.  But maybe the picklist is a package component I didn't add?  I double checked and couldn't find any missing componenets but maybe I missed it?

Also, I don't even use the Account object's Type field.  So if there's a way to ignore or exclude this field from the package and that's easier then that works too.


User-added image

Bonus: I think the app invalid cross reference error might be related to this issue (https://success.salesforce.com/issues_view?id=a1p3A000000mCIdQAM&title=invalid-cross-reference-id-deploying-custom-app-with-profileactionoverrides-referencing-new-profiles-in-same-deployment) but not sure.  Ant insights regarding that issue would be appreciated
Prakhar Saxena 19Prakhar Saxena 19
I had a similar issue. We need to include the Standard Value Set type. I updated the package.xml to include Standard Value Set along with the field and it worked.
 
<?xml version="1.0" encoding="UTF-8"?>
<Package xmlns="http://soap.sforce.com/2006/04/metadata">
    <types>
        <members>AccountType</members>
        <name>StandardValueSet</name>
    </types>
    <types>
        <members>Account.Type</members>
        <name>CustomField</name>
    </types>
    <version>46.0</version>
</Package>



 
Dimitri Shatovkin 10Dimitri Shatovkin 10
Hi Prakhar, How do I access this file ?