+ Start a Discussion
Peter BölkePeter Bölke 

Error API Version

Hello,

i am getting this error when i try to save a lightning component:
 
FIELD_INTEGRITY_EXCEPTION

Failed to save LtngCustomNewVisitReportCmp.cmp: The API version of this bundle must be set to '45' or later to use component 'markup://lightning:eventBusAPI': Source

Developer-Org has API45 but prooduction has 44. Every Component and Apex-Class has an lower API than 45 defined.

I need help! :)

thanks
Peter
Raj VakatiRaj Vakati
Your target Org(prooduction) must be 45.0 to deploy the changes

Here are the option 
  1. Wait until prod update to 45.0 version 
  2. Or Change your code to 44.0 and deploy ..
Peter BölkePeter Bölke
Hello Ray,

thanks for your comment. I tried to change to recreate the component with API 43. I can save Controller and Helper of the lightning component, but when i try to save the Cpm (Layout), then i am getting this error again.

thanks
Peter
Peter BölkePeter Bölke

i figured out that my following code causes the problem
<aura:dependency resource="markup://lightning:*" />