+ Start a Discussion
RichardC.ax220RichardC.ax220 

Report without no filtering criteria intermittently omits records

I developed a report that uses three custom objects. Two of the custom objects have a master-detail relationship and the third has a lookup relationship with the detail object. The report only has a time frame on a date in the master object as filtering criteria, yet my client has seen it omit lines that should be in the report. In the most recent case, we verified that the missing line in the report had records in all three custom objects and double checked that the client did not add any filtering criteria. The  client only has one master object, so the missing item falls in the report time frame.
 
We created a report that just shows the master and detail and it shows the line missing in the original report. So for some reason, including the custom object linked to the detail object causes the report to drop a line.
 
Has anyone else seen this? How could a report exclude a record when it only filters a time frame on the master object, and other records under the master appear? I will be glad to provide any additional information.
Jeff TalbotJeff Talbot
This is an intriguing problem in that it occurs only when you add the table with a lookup relationship to your report. Is it possible that the problem is related to date/time translations from GMT to the User time zone? If the record that is being omitted was created in the previous 24 hours, I think I'd first try changing the logged in User's time zone to GMT and see if it makes any difference.
 
If you find any other clues or a cause/explanation, I'd be very interested in reading about it.