+ Start a Discussion
New_DeveloperNew_Developer 

Duplicate values not allowed with Solutions

Hi ,

 

Iam trying to create a record type in solutions and adding a solution process to the Record Type. But its giving me error as "Duplicate values not allowed " under the Record type label. Not sure why its giving error

 

Thanks

 

farooq@consleaguefarooq@consleague

Hi

 

While creating the Record Types you need give some label name to create it . You are trying to create the record type by the same name in solution so you are getting an error as duplicate value , because the label name which you have given it may be already exist.

 

so you need to change the Label name to overcome for the error message.

New_DeveloperNew_Developer

Hi,

 

There are no other record types with the same label name. Iam able to assign the solution process to the Record types for the first time but when im editing the record type and trying to assign a different solution process then its giving me error as duplicate values not allowed.

 

Not in the world i have any idea why its giving error while assignig a solution process to record types???

 

Thanks

 

Harsh SharmaHarsh Sharma
Hi,

I am also facing the same issue!!
When am trying to change the support process associated with a Case record type, getting error: "Duplicate Values Not Allowed".

Any idea why this happening??

Thanks
Mike PeppouMike Peppou
I am having exactly the same issue trying to update the Sales Process of an Opporunity Record Type. Did you ever solve this?
sumit dhadage 9sumit dhadage 9
Hi,

I was facing the same issue when I was trying to update the support process associated with Record type. Looks like this issue is only when we update Record type though UI.

I updated Record Type from back end and it worked perfectly. I used Work-Bench to do this.

e.g. SELECT id,BusinessProcessId,CreatedById,CreatedDate,Description,DeveloperName FROM RecordType where id = 'SF Rec Id'

and then update it though code/ Work-Bench etc.
Antonio Herrera 15Antonio Herrera 15
This is a bug for the support process and the sales process updates to existin record types. This can be worked around by using the query that @sumit has provided above in either the workbench or the developer console. Thanks for your help Sumit!