+ Start a Discussion
LloydSilverLloydSilver 

Force.com IDE Error: Cannot deploy InstalledPackage in Package Manifest with any other types!

I'm trying to deploy a package from one sandbox to another and get a failure message:

 

Cannot deploy InstalledPackage in Package Manifest with any other types!

 

I'm using Eclipse version Helios Service Release 1 along with the Spring 2013 version of Force.com IDE.

 

Any clue what's going on?

 

Thanks.

 

tggagnetggagne
I heard from a coworker that while Googling around (he had more luck than I) he found folks complaining about this almost exclusively this month--suggesting it may be an API 28.0 error in the new Force IDE plugin.

I'm hoping someone finds a work-around soon, else we'll be groping around for a way to downgrade the plugin, and give-up the advantages of the upgraded API.
Lukasz SkrodzkiLukasz Skrodzki

While I'm not sure it's the best solution try to remove InstalledPackage from package.xml

More details here: http://blog.enxoo.com/en/2013/07/cannot-deploy-installedpackage-in-package-manifest-with-any-other-types-resolution/

BDArnzBDArnz

I'm getting this error but don't have "InstalledPackage" in my package.xml...

 

Anyone find a better solution?

 

<?xml version="1.0" encoding="UTF-8"?>

     <Package xmlns="http://soap.sforce.com/2006/04/metadata">    

          <types>        

               <members>CauseFeed</members>        

               <members>TestStepFeed</members>        

               <name>ApexTrigger</name>    

          </types>    

          <version>28.0</version>

     </Package>

LloydSilverLloydSilver

I reverted back to force.com ide version 27 and was able to get it to work. Clearly an issue with version 28.

Alex WeinleAlex Weinle

I've suffered from this bug too, it seems a shame that Salesforce haven't bothered to test the v28 plug-in. The only answer seems to be to revert to v27.

 

Just a couple of notes on things that don't work:

 

- changing the version tag in the package.xml back to 27 is no help.

- adding the installed package tags is no help.

 

Very poor.

 

tggagnetggagne
Does anyone know Salesforce's practice regarding bugs reported in forums? It's one thing to ignore enhancement requests but another to ignore bugs.
Alex WeinleAlex Weinle

I'm not sure what the policy is - there are certainly a few other threads on this forum of people crying into the dark about the same problem - I imagine the best solution would be for Salesforce to pull v28 until the issue is resolved.

Kelly KKelly K

Was running into this error as well - this link was more than helpful: http://salesforce.stackexchange.com/questions/14020/installedpackage-failure-when-deploying-to-sandbox

 

Guess we'll just have to wait it out util they fix the API v28.

olinessoliness

I fixed this by changing my package.xml to this:

 

<?xml version="1.0" encoding="UTF-8"?>
<InstalledPackage xmlns="http://soap.sforce.com/2006/04/metadata">
<versionNumber>1.0</versionNumber>
</InstalledPackage>

 As described here:

http://www.salesforce.com/us/developer/docs/api_meta/Content/meta_installedpackage.htm

 

Yes, the code above is the entire content of package.xml. Get rid of everything else in there and paste it in.

 

Baird_SBaird_S

I'm unable to revert to Version 27.  I don't seem able to delete the Force.com IDE - I get a select for Force.com IDE (Profile), and choose that, and uninstall.  I'm asked to confirm, and I do.  I'm informed that I'll have to close Eclipse adn reopen it.  It closes and reopens.  I go to the Software and Sharing Center, and find Force.com IDE 28.0.0 still there.

 

I've tried multiple times.

 

Can anyone describe to me how to overcome this?  Or, otherwise, where do I find the package xml files generated for the deployments, so I can remove the offending code?

 

Thanks.

Alok AgrawalAlok Agrawal

I just updated force.com ide to version 28.0.1 and am not facing this issue anymore. Looks like the latest version fixes this issue. :)

Ashish_SFDCAshish_SFDC

Hi Alok, 

 

Thank you very much for updating here.

 

Regards,

Ashish

Baird_SBaird_S
Update: I eventually had to delete the IDE and then go in and delete Eclipse. Then reinstall Eclipse Helios from scratch. Then use the add software function to add the Force.com IDE, and choose versieon 27.
kirkevonphillykirkevonphilly

I too was having the same issue with the initial 28.0.0 plug-in.  Saw there was a 28.0.1 waiting in the Software Center and updated.  For me, the problem only went away after updating, restarting, and then rebuilding a new Project with the component (Object in this case) that I was attempting to save.