+ Start a Discussion
Lee_CampbellLee_Campbell 

Data Loader missing fields on export

Hi folks,

 

I'm trying to export some of our opportunity data using the Data Loader, and one of my custom fields is missing. It's a text formula that about half of all profiles can see. I have a different text formula that not everyone can see as well (there is some overlap as to the profiles that can see it), and that downloads fine, so that covers the field type and permissions... I can't think of what other variables (except Data Loader temperament!) could be causing this rather weird phenomenon. Any clues, folks?

 

Thanks,

Lee

Cloud CredenceCloud Credence
Hi,

It has to do with Field Level Security only.

Goto the fls of that field(as well as the other fields that you had used in that forumula) and see whether those are visible to the profile that you are using for data loader.

Thanks
Lee_CampbellLee_Campbell
Hi,



Thanks for your reply. The field is visible to the profile I'm using in
the Data Loader (System Admin), as are the fields it depends on. I made
sure of that first, probably should have explained myself better in the
first place. Any other suggestions?



Lee
Cloud CredenceCloud Credence

Hi,

 

See whether you can see those fields using Eclipse Salesforce Scheme window.

 

System Administrator does not mean the field is visible to him on querying. You can make a field inivisible to Sys Admin , and it will not be visible in reports, page layouts to him, but will be visible in set up ->customize.

 

Also please make sure the API name of the field is what you are looking for in data loader. Probably they have a completely different API name.

 

See whether the field is visible to you when you try it in a different machine's data loader(just curios).

 

Thanks