+ Start a Discussion
RRESRRES 

URGENT - Page ModifyLicense does not exist

I'm using LMA to modify a license for a new customer and since the new update I'm getting the following error:

 

Page ModifyLicense does not exist

 

I need this fixed ASAP or I can't provision licenses for my apps. Any ideas?!

Message Edited by RRES on 06-09-2009 10:12 AM
dburkidburki

Hi,

 

We know about this issue and it's being very actively troubleshooted as I write. So, there should be a solution soon.

 

Meanwhile, there is a workaround - not pretty but gets you what you want. Take one of the page layouts and add license fields - Status, Expiration Date and Seats - to it. Assign that page layout to your profile. Then, you can click the "Standard Edit" button to edit the license. Since you are doing it in a way NOT recommended (it is not recommended as it is not user-friendly and is prone to user confusion), keep in mind the following: in the standard edit page, if you want to set the number of licenses to site license, set seats = -1. If you want the license to never expire, set expiration date to null.

 

If you have further questions, email me at dburki@salesforce.com.

 

Dileep

 

ShinShin

I have a same problem, but the W/A above is not useful because all field security is automatically set to "Read

 

Only" when creating new layout. Is there any way to avoid this ?
Greg HGreg H

You need to add the "Edit" button to the new page layout.

-greg

WasulaWasula
Any ETA on a fix date?  We're having the same issue.
shillyershillyer

Hi Shinichi,

 

Did you do the following?

1. Create a new page layout on the License Object based off Edit License Layout

2. Remove License Status, Licensed Seats and Expiration Date from the layout - these fields will be read-only

3. Add Expiration, Status and Seats - these fields are NOT read-only

4. Add Edit button to Standard Buttons - and remove Modify License from Custom Buttons

 

If you did the above and still encountered a problem, please let us know.

 

Hope that helps,

Sati

Message Edited by shillyer on 06-15-2009 02:54 PM
jasoncjungjasoncjung

Hi Dileep,

 

Is there any resolution or bug tracking # so we can monitor the status of this?

 

Thanks,

Jason 

dburkidburki

Hi,

 

We are actively working on a solution. Although I cannot commit to a date yet, there is a good likelihood that it will be fixed by EOD tomorrow (Wed).

 

I will keep you all posted.

 

Meanwhile, please use the workarounds mentioned in this thread.

 

Sorry for the inconvenience; we are actively working on a fix.

 

Dileep

dburkidburki

Hi,

 

I am glad to inform you that this problem has been fixed. Sorry once again for the inconvenience.

 

Dileep