+ Start a Discussion
sandersensandersen 

Triggers and the Account/Contact import wizard

I have some before and after insert triggers on Contact. When a Contact is imported via the Account/Contact import wizard, the triggers don't behave as expected. All my tests are passing--one-offs and bulk.

 

My question is, how do I troubleshoot a problem like this? I can't write a test that uses the import wizard. Import wizard DMLs don't appear to be recorded in the debug log. I'm not sure where the dupe checking of the import wizard fits in the execution stack--it's not listed in the Apex docs that talk about execution order.

 

Is there any way for me to see what might be happening here?

 

Thanks,

Steve 

jeffdonthemicjeffdonthemic

Steve,

 

I've seen similar issues. We have triggers on Accounts that function fine, pass all tests and work properly using the data loader. However, these triggers would error when doing a mass transfer of accounts. I submitted a case with Salesforce.com but not sure what the resolution is. I'll check into it some more and post an answer here.

 

Jeff Douglas

Appirio

http://blog.jeffdouglas.com 

Alan.MarcusAlan.Marcus

Hi Jeff,  did you ever hear back from SFDC?  I am experiencing the same issue - my triggers wont fire when using the wizard

 

The triggers only fired when importing through the data loader....

 

 

 

Message Edited by Alan.Marcus on 08-25-2009 04:18 PM
sandersensandersen

I have nothing new to report. Just picked up this issue again. I'll see if I can find anything.

 

Thanks,

 

Steve 

jeffdonthemic2jeffdonthemic2

Salesforce.com has confirmed that the issue is indeed a bug and they has escalated it for work for the next release. I'll let post more when I hear any updates.

 

Jeff Douglas

Appirio, Inc.

http://blog.jeffdouglas.com 

sandersensandersen
Thanks Jeff!
jesperfjjesperfj

Hi Jeff,

 

Do you have a case #?

 

Jesper

 

jeffdonthemic2jeffdonthemic2

Jesper,

 

The case is 02761077. According to the email on Aug 5th, it is being worked on by R&D. I've been told the fix should be in place with the next release (safe harbor).

 

Their workaround for now is to only run the mass transfer of records owned by a single user.

 

HTH 

 

Jeff Douglas
Appirio, Inc.
http://blog.jeffdouglas.com