+ Start a Discussion
pbattissonpbattisson 

SVN Test Not Compiling

FailuresHey everyone

 

I am a newbie iOS/Objective C developer and have just downloaded the iPhone SDK and XCode and successfully got a "Hello World" app running on the iPad/iPhone simulator.

 

With this success I then downloaded the Force.com iOS toolkit and tried to run the SVNTest project but get "BASE SDK missing" errors and the drop down list in the top left is empty along with a series of "red frameworks" see the following pic:

 

 

If it doesn't display it is at http://www.twitpic.com/4c29xq

 

Thanks for your help in getting it working.

 

Paul

Best Answer chosen by Admin (Salesforce Developers) 
pbattissonpbattisson

OKay, solved my own issue. Installing a fresh install of the latest SDK means you have to change some of the project settings and ensure you are running it as a simulator. Gonna drop Quinton and Dave a mail to let them know.

 

For the record:

 

Project -> Edit Project Settings -> Base SDK iOS 4.3

 

Then

 

Project -> Set Active SDK -> Simulator

 

Should do the trick.

 

Paul