+ Start a Discussion
DBManagerDBManager 

Visualforce PDF not displaying in Internet Explorer 8 or 9 for some users

I have encountered a really strange problem that, despite trawling teh internets and the dev forums, I can't seem to solve. It is also very confusing, and seemingly has no pattern to it.

 

I have setup a Visualforce page that renders to PDF, and can be opened and printed from the Opportunity page.

 

However, one user seems to be unable to open the page from Internet Explorer 8 on her machine. When she tries to open the page, a window opens with the correct url, but before it loads the page, it cancels itself.

 

Her profile and role are the same as mine (admin), yet when I log on to SF on her machine, I can open the page in IE without any problem. To add to this, if she logs on in Firefox on her machine, or in Chrome on a Windows 7 machine, she can access the page ok.

 

Stranger still, if she logs on to IE9 on the W7 machine, she cannot access the page - it just repetedly rediects her back to the SF login screen. But if I log on to the same browser/machine, after one extra login, I can access the document.

 

Note that, whilst we have the same profile and role, I have the admin functions ticked in my user profile, whilst she does not.

 

Also note that I have tried 

cache="true"

and

standardStylesheets="false"

in the page descriptions, but neither solve the problem.

 

Can we find a solution, or is a browser change the only option?

 

Thanks in advance.

mackendw@gmail.commackendw@gmail.com

I have a very similar issue to yours.  I have a VF section on the Opportunity with an "Export as Attachment" button which does a renderAs='pdf' of the contents of the vf section.  Works in FF, Chrome - NOT in ie 8 or 9.   It is indicating in an error dialog that the attachment is corrupt or broken.

 

wtf??

DBManagerDBManager

BUMP...

 

This seems to be related to the renderas="pdf" function, as setting to HTML renders fine.

 

Anyone had any other experience of this and found a solution?

 

Thanks.

VrodaVroda

I don't know if you resolve this but I had the same issue and was able to resolved. Ordinary users do not have developer mode checked ver myself as admin. But issue was IE setting.