+ Start a Discussion
RichardC.ax220RichardC.ax220 

S-Control works OK, except in read only Test Drive

I am setting up a test drive for a managed app. The app includes an S-Control that queries several custom objects to populate select boxes. This S-Control works fine installed in user organizations and for the test drive administrator. However, It fails for the read only eval user in the test drive. Each query fails with the message "INVALID TYPE: sObject Type ... is not supported." I verified that the user can (only) read the objects in the profile. Does anyone know what's causing this problem, or a way around it?  Thanks! 
TCAdminTCAdmin
Hello Richard,

The read only profile will not allow your sControl to write to any field on any objects.  This will always give you an error.  You can fix this by cloning the profile and giving them permissions needed.  You can still lock down the field-level security of the fields that you do not want then to be able to modify but let them write to the fields needed to allow the feature to work. 

Your other option is to disable the feature within the demo but put screenshots of the results.  Then have another developer edition which has the feature enabled that you could direct customers to that contact you.
RichardC.ax220RichardC.ax220

Chris,

Thanks for the useful suggestions. It turns out that all I needed to do was deploy the app as the test drive admin user. Now the eval user with a read only profile can use the S-Control just fine.