+ Start a Discussion
kdfskdfs 

Record Type not available

Hi Experts,

We are facing one issue with the record type. The problem is the record type selection page is not displaying for the user after clicking "New" button for task object.

At profile level we given permission for the record types for Task object but still not able to see those record type after clicking "New" button for task object.

For the other users with the same profile, they all are able to see the record type selection page except for one user.

Looking forward for your valuble ideas on this.

Regards,
Priya
Best Answer chosen by kdfs
Vamsi KrishnaVamsi Krishna
Priya
can you check for the user if there is any default record type selected in their personal settings.. if its selected, the record type selection will not be displayed.

reference
https://help.salesforce.com/HTViewHelpDoc?id=user_recordtype.htm&language=en_US

All Answers

Vamsi KrishnaVamsi Krishna
Priya
can you check for the user if there is any default record type selected in their personal settings.. if its selected, the record type selection will not be displayed.

reference
https://help.salesforce.com/HTViewHelpDoc?id=user_recordtype.htm&language=en_US
This was selected as the best answer
kdfskdfs
@Arun Kumar:  We have the record type at profile level only not user permission set.

The following error message displaying after clicking "New" button of Task object only for that user.

Record Type is Unavailable Your attempt to create or clone a record involved a record type that is not available. If the record type is valid, ask your administrator to assign access to you.
Error Message (PFA)
Click here to return to the previous page.
kdfskdfs
@Vamshi Krishna : Thanks you so much for the reference. It helped alot. Now the issue got fixed. Thanks once again.