+ Start a Discussion
Amanda ReamAmanda Ream 

Apex Trigger Change Set Failed because Sandbox Environment is on Summer 14' and Production is Still on Spring 14'

This is the error I received:

"All components failed Version Compatibility Check.
Every component in this change set requires the "31.0" or higher platform version. Please select an organization with a platform version of "31.0" or higher"

What do I do in this situation, wait until Production has been upgraded to Summer 14'?
karnadesaikarnadesai
Roll back your code to version 30.0 of the API to deploy now, you can do this using Force.com IDE
Amanda ReamAmanda Ream
Thanks! Is there anyway to do it with Eclipse or the Console? I am a newbie and not really familiar with the Force.com IDE. 
karnadesaikarnadesai
You can also do with Eclipse ( Force.com as a Plugin), for each Apex classes, triggers or VF pages there is meta.xml file which you can edit for changing version.

Alternatively when you edit on browser you can go to version settins tab and update version as well.
Amanda ReamAmanda Ream
Got it. Thanks!