+ Start a Discussion
BrockBBrockB 

Unsupported API version 31.0 (Bulk API)

All of the documentation I have been reading (which seems to be the latest version) uses API version 31.0
I am tring to login as described here:

https://www.salesforce.com/us/developer/docs/api_asynch/Content/asynch_api_quickstart_login.htm

And just get this result.
<faultcode>sf:UNSUPPORTED_API_VERSION</faultcode><faultstring>UNSUPPORTED_API_VERSION: Invalid Api version specified on URL</faultstring>

Am tring to login to the sandbox environment so using these URLs:
Same result for both URLs:

https://test.salesforce.com/services/Soap/u/31.0
https://test.salesforce.com/services/Soap/c/31.0

When I change it to version 30.0, it works ok.

I'm worried by reading the 31.0 documentation and using api version 30.0, I will end up wasting time trying to get something to work when it never will.

Please help

Best Answer chosen by BrockB
James LoghryJames Loghry
Version 31.0 is Summer '14.  

Summer '14 has not been applied across all orgs yet, and is due to rollout later this month.  See here for the tentative schedule: http://trust.salesforce.com/trust/maintenance/

It's possible you've grabbed the Bulk API WSDL from a Summer '14 org and are trying to connect to a Spring '14 org, and it simply errors out.

Using the 30.0 api version should be fine if you're not dependent on new Summer '14 functionality.  Otherwise, you'll have to wait until Summer '14 hits your pod.

All Answers

James LoghryJames Loghry
Version 31.0 is Summer '14.  

Summer '14 has not been applied across all orgs yet, and is due to rollout later this month.  See here for the tentative schedule: http://trust.salesforce.com/trust/maintenance/

It's possible you've grabbed the Bulk API WSDL from a Summer '14 org and are trying to connect to a Spring '14 org, and it simply errors out.

Using the 30.0 api version should be fine if you're not dependent on new Summer '14 functionality.  Otherwise, you'll have to wait until Summer '14 hits your pod.
This was selected as the best answer
BrockBBrockB
Ok thanks for the info. I will continue to use version 30.0