+ Start a Discussion
Sheri@SupportPaySheri@SupportPay 

Error Occured while loading a VisualForce page - NetworkError: 500 Internal Server Error

I have a custom product built on the force.com platform. After the recent update on many of my pages when I go to navigate to them a generic force.com error page occurs that says Error: Error occured while loading a Visualforce page.. When I look at the console errors there is an error that says: "NetworkError: 500 Internal Server Error - https://oursandboxinstance.cs16.force.com/All_Documents".

A few things to note:
1. This only started after the most recent update from Salesforce (started seeing this Dec 4th, 2014)
2. The error page is different than the error pages I see when there are errors in the access / coding. Those errors have a custom template that we use (our own exception page).

Any ideas why this is occuring?

I am seeing this on a redirect page to our dashboard page after login. I am also seeing it when I launch a component and try to save a document which requires a refresh of the table.

I tried updating the API version of the page and the components and that didn't help.
 
Sheri@SupportPaySheri@SupportPay
I finally figured out the issue... though I still don't know why.

Since this is a completely custom front end we had applyHTMLtag="false" in the template.

I haven't had problems in the previous version but after the upgrade that happened this past week it broke some of the pages (though not all of them).

After I removed applyHTMLtag="false" from the template our pages began working again.