+ Start a Discussion
Gaurav Srivastava_SDFCGaurav Srivastava_SDFC 

Invalid Component tried calling function error while accessing related OLI in salesforce1

Hi Folks,

I have created a VF page for Salesforce1 to add OLI. Once OLI is added user is redirected back to Opportunity detail page. But when user tried to view added OLI in the related list section below eror is thrown. Please check te snapshot below.
User-added image

Any solution for it??
Gaurav KheterpalGaurav Kheterpal
Looks like you're either not passing the arguments correctly or your callback function definition is not correct. Do you mind sharing your code snippet?

If my answer helps resolve your query, please mark it as the 'Best Answer' & upvote it to benefit others and improve the overall quality of Discussion Forums.

Gaurav Kheterpal

Developer Forums Moderator| Certified Force.com Developer| Dreamforce Speaker| Salesforce Mobile Evangelist
 
Gaurav Srivastava_SDFCGaurav Srivastava_SDFC
Hi Gaurav,

Thanks for reply. This is happening when I am trying to access child OLI of the Opportunity. As I click on the related section of OLI, which is standard one above error is thrown. To my surprise it is only happening on Browser version of Salesforce1. When I am accessing this related section from Phone device or ipad, it just works fine. Also, aurgument you can see in the screenshot is used no where in the code. I believe Salesforce is internally using same argument in their code and thus this issue is being created.

Regards,
Gaurav