+ Start a Discussion
Sanpreet AroraSanpreet Arora 

Trailhead UI Customization Buttons and Links Problem

Challenge Not yet complete... here's what's wrong: 
The 'Google Info' custom button does not appear to be linking to 'google.com' and passing the Contact's Name field.Error can't able to complete challange.
Amit Chaudhary 8Amit Chaudhary 8
Please check below post for more information
1) https://developer.salesforce.com/forums/?id=906F0000000AugZIAS
2) https://developer.salesforce.com/forums/?id=906F0000000AvMMIA0

Not Using Default "Contact" Object to Create Button
Are you creating the custom button under Build > Customize > Contacts > Buttons, Links, and Actions (as seen in the image below)? Many users are creating a new custom object called "Contact" instead of using the default object as the challenge calls for.

When creating the button, are you using the Detail Page Button display type? Using one of the other two options will fail the challenge.

Are you using Page Layouts under Build > Customize > Contacts? You will need to edit the layout titled "Contact Layout".


 
Sanpreet AroraSanpreet Arora
Yes i had created custom button under Build > Customize > Contacts > Buttons, Links, and Actions i am facing this error message "Challenge Not yet complete... here's what's wrong: 
The 'Google Info' custom button does not appear to be linking to 'google.com' and passing the Contact's Name field" and Button name is ''Google Info" and Action is "http://google.com?q={!Contact.Name}" but still same error.
Sanpreet AroraSanpreet Arora
User-added imageUser-added imageUser-added image
E TurnerE Turner
I receive the same error message when checking the challenge.
jon.klingensmithjon.klingensmith
Seems to be something else going on here - I am getting the same error.

I have determined that the test routine is finding the button (so it's in the right place and is named properly), and using the button works interactvely. Here is the URL: https://google.com/#q={!Contact.Name} 

 
Robbin Hall-BaggettRobbin Hall-Baggett
mine worked once I used jon,klingensmith's google code. Like you, everything was where it was supposed to be. I think the trailhead module has provided code that is not written correctly.
Amit Chaudhary 8Amit Chaudhary 8
Please check below post with step by step process with screen shot
1) https://developer.salesforce.com/forums/?id=906F0000000BPIOIA4
2) https://developer.salesforce.com/forums/ForumsMain?id=906F0000000D87ZIAS

To clear this challange you need do below steps:-

Step 1 :- Create a Button on contact object like below 
Step 2 :- Link detail should be like below.

Button or Link URL :-  http://google.com/#q={!Contact.Name}
Display Type :- Detail Page Button

Step 3 :- Add the button on contact page layout. Please select "Contact Layout"
Step 4 :- Then click on Edit and add button on page.
Step 5 : - Save.

Please let us know if this will help you.

If you've got a few Record Types you can check which one is assigned to the System Administrator profile from their profile page.

Please check which page layout it assigned with your system admin profile.
If possible then please share your user and password with me on my email ( amit.salesforce21@gmail.com ) i will check is the issue in your DE org .

 
Gbolahan JolapamoGbolahan Jolapamo
Has anyone figured the solution or informed trailhead about thyis issue?? Its still returning same error today even when the button functions properly.
Keith JinKeith Jin
Gbolahan,  I was banging my head against this one as well.   Make sure you are dragging FROM  (in page layout editor) from 'Buttons' and not 'mobile and lightning actions'.  And make sure you are dragging TO 'Custom Buttons'  not 'Actions.

It's a little confusing since the end result looks the same,