+ Start a Discussion
Sreenivas MSreenivas M 

When we Einstein bot with whatsapp all the dialog messages are going in single block

I have a einstein which is attached to whatsapp channel,i have 2 different dialogs in bot,the first one will answers the question and second dialog basically ask the customer regarding feedback question.

On web chat these 2 messages are coming separately one by one but where in case of whatsapp all these 2 dialogs are going as single message so customer is couldn't identify the feedback question actually we are asking.User-added image
Best Answer chosen by Sreenivas M
Sreenivas MSreenivas M
According to the salesforce documentation it has been implemented in such way that all the messages in digital enagagement channels (whatsapp,facebook etc) the delay between the messages will be discarded. Because of this all the messages will be come in single block.Even if we tried using setting up the delay with flow it will not work.

https://help.salesforce.com/articleView?id=sf.bots_service_deploy_to_channels.htm&type=5

User-added image

All Answers

ANUTEJANUTEJ (Salesforce Developers) 
Hi Sreenivas,

>> https://www.wearemarketing.com/blog/salesforce-whatsapp-integration-release.html

The above link has the details mentioned can you try checking if all the steps are proper?

Let me know if it helps you and close your query by marking it as solved so that it can help others in the future.  

Thanks.
Arthur AlmeidaArthur Almeida
Hello Sreenivas M, how are you?

I'm the same problem, how do you resolve it?
gfdbgv vgfdgbvdgfdbgv vgfdgbvd
Yes Its very interesting question and I am also looking for this type of information to add in my new project you can see here on this link (https://onmarketingofficial.com/rudn-enclave/).
Sreenivas MSreenivas M
According to the salesforce documentation it has been implemented in such way that all the messages in digital enagagement channels (whatsapp,facebook etc) the delay between the messages will be discarded. Because of this all the messages will be come in single block.Even if we tried using setting up the delay with flow it will not work.

https://help.salesforce.com/articleView?id=sf.bots_service_deploy_to_channels.htm&type=5

User-added image
This was selected as the best answer