+ Start a Discussion
tina sharma 10tina sharma 10 

field level access in profiles

I am working on the trailhead link : Control Access to Fields
Learning Objectives
https://trailhead.salesforce.com/content/learn/modules/data_security/data_security_fields

I cloned the profile "Standard User", but I am not understanding how salesforce as mentioned to give Field Permissions: Rating field of account object.

So this is stopping me from completing my trailhead.

Thanks
Tina
Best Answer chosen by tina sharma 10
Deepali KulshresthaDeepali Kulshrestha
Hi Tina,

I have gone through your question. To give Field Permissions to Rating field of account object you have to follow the steps:-

1:- GOTO Setup ----> In Quick Find Box type "Profile" ----> Goto Profile ---> Scroll and Goto Field Level Security.

2:- In Field Level Security ---> Click View Button in front of Accounts ----> Edit ---> Find Rating and remove the tick form 
both the checkbox.

3:- Click Save.

Thanks and Regards,
Deepali Kulshrestha
www.kdeepali.com 

All Answers

Lokesh KumarLokesh Kumar
Go to the newly created permission set created by the following steps mentioned in the challenge.
Create a new permission set with the following settings:
Label: Rating
API Name: Rating
User License: Salesforce


Provide Read and Edit access through permission set to the Rating field on the Account object. Here is the link on how to give field permission to the Permission Set.
https://developer.salesforce.com/docs/atlas.en-us.securityImplGuide.meta/securityImplGuide/users_profiles_fls.htm
Deepali KulshresthaDeepali Kulshrestha
Hi Tina,

I have gone through your question. To give Field Permissions to Rating field of account object you have to follow the steps:-

1:- GOTO Setup ----> In Quick Find Box type "Profile" ----> Goto Profile ---> Scroll and Goto Field Level Security.

2:- In Field Level Security ---> Click View Button in front of Accounts ----> Edit ---> Find Rating and remove the tick form 
both the checkbox.

3:- Click Save.

Thanks and Regards,
Deepali Kulshrestha
www.kdeepali.com 
This was selected as the best answer
tina sharma 10tina sharma 10
@ Deepali

Ya I saw Field Level security in the profile, 

Thanks, this worked.