Error
This content is not currently supported on this browser.
+ Start a Discussion
Alex MoralesAlex Morales 

async API not enabled

When I am trying to bulk import my .zip (all data exported from production) into my sandbox using the Apex Data Loader, I get an error message that says "async API not enabled."  How can I enable this feature?  I am using Enterprise edition.  Thanks!

jhurstjhurst

Alex,

 

I am not quite sure why the sandbox refresh did not bring the Bulk API perm over.  Is this a very old sandbox?

 

Can you log a ticket with support and include your Sandbox Org ID and your Production Org ID.  Then add a response to this thread with your case number, and I will see that it gets resolved.

 

Hope this helps.

Jay

dsalkodsalko

Hello

 

Was the problem solved and how?

 

thanks!

jhurstjhurst

DSalko,

 

The Async API is enabled by default for all DE, EE, and UE orgs.  Any sandbox created from one of those editions after the Bulk API went GA (about a year ago) will also have the Bulk API enabled.

 

Please let me know if you are receiving the same error and I can take a look.

 

Jay 

dsalkodsalko

Hello,

 

Thanks you for reply. It's complicated - because I'm one of developers of Snapshottool for Salesforce  

https://crm.snapshottool.com

 

And one of our clients complains about problems. I've checked errors log for this user - and it was 

 

Async API not enabled [FeatureNotEnabled]

 

for 66 entities. 

 

Should I recommend this user to contact Salesforce support? Any other suggestion?

jhurstjhurst

I can check the org, but I would need a username or orgId.  It is probably best to have the customer open a support case (or you may want to open a case for them) andthen let me know the case number.  From there I can see what is going on.

 

Thanks

Jay

Mike WheelerMike Wheeler

I received this same error message 'async API not enabled' while trying to export all of my Contacts out of production. I had recently updated to the Winter 13 (26.0) release in my enterprise org, but was using Data Loader version for 25.0.2. I downloaded and installed the latest Data Loader 26.0 and was able to then export the Contacts w/o a problem. So for those out there hitting this error message, try updating your Data Loader.