+ Start a Discussion
Randi RabeRandi Rabe 

Change set upload error, no specifics given

I've attempted to upload the change set 5 times, but none of them worked. For some reason, I'm not receiving the emails from SF telling me why it failed, I had to have another admin do it so that I could see the error message. As you can see below, it doesn't give me any specifics about what I need to fix. This is my first time doing any of this as I'm a new admin, so it's likely user error I just don't know where to start to fix it.

The following outbound change set upload failed due to a system error: Change set: First round EPL release (0xxx00000002U1V) Organization: TEST (Developer Sandbox) (00Xx0000003xxxx) User: SFDC Admin (xxxx0000000xxxx) Error Number: 2026248261-2941 (245827274) Please try to upload your change set again. If it does not succeed, contact Customer Support and provide the error number listed above.
 
Best Answer chosen by Carlos Campillo Gallego
Randi RabeRandi Rabe
Hi, I was about to reply to you as well! I worked with one of the developers in the @salesforcedevs group on Twitter and we broke my change set into parts as well. First I brought over my profiles. Then I removed all tasks, reports and dashboards. Once I removed everything except the object and fields, it downloaded and validated perfectly. I didn't realize that tasks couldn't be brought over and would have to be re-added to the org. Also, I highly recommend joining the @salesforcedevs group on Twitter, they helped me a lot more than CS did. Thanks!!

All Answers

Vijay NagarathinamVijay Nagarathinam
Hi Randi,

Refer the following links, that will be helpful to resolve your issue.

http://help.salesforce.com/HTViewSolution?id=000003280
https://success.salesforce.com/answers?id=90630000000CqV9AAK

You can try to deploy by using Force.com IDE or ANT tool.

Please let me know if you need any help regarding this.

Thanks,
Vijay
Randi RabeRandi Rabe
Hello, neither of those links apply to my issue. I don't have any custom apps assigned to the profiles I'm trying to upload, and both our sandbox and our org are in Spring '16. I am not a coder in any sense of the word, so IDE or ANT is not really a viable solution. What other options do I have to get this resolved? This is urgent, I have been trying to upload this change set for a week.
Sheila Northrop 8Sheila Northrop 8
Yes, please someone advise - I am having the same issue and Salesforce is less than helpful.As far as I can see there is no reason why this should fail.
Sheila Northrop 8Sheila Northrop 8
Ok - I split my change set up and located the issue, or at least narrowed it down to 2 items. I was trying to add a letterhead and a folder and one of them failed. So... I'll just add them directly instead. I hope that helps you too, Randi.
Randi RabeRandi Rabe
Hi, I was about to reply to you as well! I worked with one of the developers in the @salesforcedevs group on Twitter and we broke my change set into parts as well. First I brought over my profiles. Then I removed all tasks, reports and dashboards. Once I removed everything except the object and fields, it downloaded and validated perfectly. I didn't realize that tasks couldn't be brought over and would have to be re-added to the org. Also, I highly recommend joining the @salesforcedevs group on Twitter, they helped me a lot more than CS did. Thanks!!
This was selected as the best answer
Sheila Northrop 8Sheila Northrop 8
Thanks - will definitely follow your suggestion.
 
Mary Jean OHairMary Jean OHair
Thanks for posting the information on the change sets.  I am also new to Salesforce and have been looking everywhere to resolve the deployment issue.  Based on your suggestion I broke down my initial change set to the user profiles, apps, custom objects and custom fields and it worked.  I will put the rest in the next change set.  Thanks again