+ Start a Discussion
M.M. 

SSL support is not available in this build

Hello everyone...

I'm having an error while trying to access salesforce through php...

"SSL support is not available in this build"

Hou can this be solved?

thank you!

M.
Best Answer chosen by Admin (Salesforce Developers) 
danlatdanlat

Hi,

 

 

You need to also uncomment the following extension line in php.ini:

 

extension=php_openssl.dll

All Answers

Park Walker (TAGL)Park Walker (TAGL)
This is probaly an indication that the SSL library files are either not on your path or are not the correct version for the version of PHP that you are using. If you are using PHP 5.2.X the correct files are in your PHP root directory. The files to look for are libeay32.dll and ssleay32.dll. Check to see if to see files exist in your system32 directory. If so, rename them, copy the ones from your PHP directory there and reboot. If they are not already there you can just copy them there.
danlatdanlat

Hi,

 

 

You need to also uncomment the following extension line in php.ini:

 

extension=php_openssl.dll

This was selected as the best answer
dbibbydbibby

I would just like to say that I was having this problem as well.  The Fedex shipping options was not displaying.

Finally looked at the log and found this errror -> SSL support is not available in this build

Searched, found this post and enabled the php_openssl extension

It worked.

So happy, I took the time to comment here. 

Many thanks